MQTT Connection lost no further connection possible

Don't know what happen in detail, while changing layout of dashboard my connections to the running mqtt server inside iobroker get lost. I find no way to reestablish the connection. Inside ioBroker the mqtt service is running. Tried several thing of course restart iobroker
then apt update and apt full-upgrade some effect, all my flows do not get connection to the running mqtt server, even there are no error's inside the iobroker log. Help would be great.

Sorry, never used that. You may need to ask in their forum rather than here.

Is the mqtt broker on the same machine as node-red?

Are you accessing the broker using its IP address? Perhaps that has changed.

Are you able to connect to the broker using something like MQTTExplorer?

Inside ioBroker I am using mqtt server adapter and nodred plugin ...

Before every thing was working without errors, after changing layout of dashboard the connection get lost. I was trying to make a restore a version from day before, this was successful but same situation no connection to mqtt server

Yes same maschine, access via ip and port, nothing was changed, the only thing that chanced is lost connection. Even when I establish a new mqtt server with different name, there is no connection possible.

Never worked with a MQTTExplorer ... is it an addon?

Google it. It is an application you can install that is extremely useful for testing MQTT.

You didn't answer that. Show us how you have configured the broker node in node-red. Also show us a screenshot in node red showing it not connected. You can paste an image here directly.

Do you know how to find the node-red logs in that environment? If not then you will probably have to ask on a relevant forum. Once you have found them then post what the log shows on starting node-red.

Fount MQTTExplorer will check out and send result in shorten

what I found is that inside iobroker there is no connection to nodered project ... before my crash I
had connections to see picture

My question is how to tell nodered to connect a project, seemed this could be the source of failure

Sounds like something you have changed in the flows is crashing node-red. Most common cause is creating a loop in your flow.

You will need to research how to start node red in safe mode on io broker.

Running node red outside of a container like io broker is simple but I don't know if io broker has any options to pass the safe flag to the startup.

What do you see if you look at the mqtt nodes in the node red editor?

Also show us how they are configured. In particular the server settings inside the mqtt node setup.

Hi Collin, there was no change in configuration of mqtt node, i will enclos a picture of my configuration
and before crash the mqtt node setup was working fine without errors, but inside log there is message see
Projekte deaktiviert: editorTheme.projects.enabled=false

That is not a normal node-red mqtt config node. It should look like this

So it seems that the node-red you are using is much modified. I think you may have to go to a different forum to get this answered.

Do your node-red flows show correctly? If so what does the mqtt node look like?

This is my mqtt server setting it looks like Your settings

So is that the right IP address? Is that the address that you have used in MQTTExplorer.

The node should have a connected or disconnected status under it.

I presume you have tried a reboot.

Yes right IP address, see all topics in MQTT Explorer, so I think that MQTT Server is working and all messages are deploying, only inside node-red there is no display, the MQTT Explores showing all information, and every second there will be changes, so that the MQTT Server is in my opinion working.
But by clicking on a injection node nothing happens, because there is no connection inside the nodes
See picture

... what I will try next, not today but tomorrow, I will reinstall the mqtt instance and if it is furtheron not working I will reinstall iobroker and afterward I will restore my flows,
... thanks so far ... will keep You informed

Is the broker running on the same device as Node-RED? If so, that connection should be localhost not the IP address. By using the address when they are all on the same machine, you are forcing the connection to go via the external network interface which adds complexity - more things to go wrong. Also likely to be slower and, certainly on older Pi's, will use more CPU.

SOLVED only by reinstall of ioBroker at all,
was trying several things, starting with simple things

  1. atp update / atp upgrade /reboot
  2. checking and possible iobroker upgrade self (no effect everything was up to date)
  3. several restarts
    --> no effects furtheron no connection nodered to mqttt even by changing ip-adress to localhost entry
    by the way thanks for hints from TotallyInformation :slight_smile:
    Next steps single reinstall of
  4. NodeRed
  5. MQTT Server
    --> no changes same results
    than next
    **curl -sL | bash -**
    reinstall and reconfigure mqtt Server, NodeRed, reinstall all flows from backup
    and now connection is possible, everything is working fine again ... the pitty finally I don't know what happen exactly but one thing nodered need to have a connection entry see picture

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.