No module named rpi_rf Import Error (433 mhz sender reciever)

Hi,
i have this fault message when i run the code for the send with python3-function on node red. Same code working without any problem with Thonny IDE. Somehow import of rpi_rf working not corectly. Does anyone has an idea, what the issue is?
thanks

had a similar issue.

The following solved my problem:

apt-get install python3-pip
pip3 install rpi-rf

I tryed already. But nothing changed. :frowning:

Are you calling the script via the exec node?

It should work if you would put this:

/usr/bin/python3 /home/pi/.node-red/myFolder/myScript.py

into the command field.

1 Like

Actually no. I am running the code in function python modul. How did you you do? My goal is sending decimal code from OpenHab over node red.

I am using this script send.py.txt (1.2 KB) and just call it with the exec node. The payload passed to the exec node goes directly to the script as argument - and the script just uses the Pi's GPIO Pin.

I made a button that sends 16777099 as payload to the exec node to turn on RGB lights for example.

1 Like

Thanks. I am going to try this way. Give you fb.

+1 for using an exec node, or rewrite the function in javascript. Others have had issues with the python nodes.