Node-RED 0.20.0 Released


#1

After a few beta releases, Node-RED 0.20.0 has now been released for general use.

Checkout the release blog post, including video, to find out what's in it - https://nodered.org/blog/2019/03/12/version-0-20-released


#2

the images on the blog are not there?


#3

upgraded main PiZero and getting broker error msgs but could be co-incidence


#4

sigh.... they are now, or will be once Github catches up after its outage earlier.


#5

I'm getting this in my function dialogue boxes, they still work so it must just be a display error.


#6

I've just upgraded a RPi-2 to the 0.20.0 release and everything seems to work fine.

I've got a RPi-3+ and a couple of RPi-Zero-Ws that I'll upgrade tomorrow (once I'm satisfied the RPi-2 is happy).


#7

Seems fine on my PiZero, Pi2 & Pi3. Looks to be specific to just one of my Pis. I;ll try a fresh update and see if that fixes it.


#8

Can't connect to iot.eclipse.org using MQTT explorer from my Win10 PC either so just a co-incidence!


#9

RPI 3B+ upgraded with no problems!


#10

Nope, still getting the same result after running the update script. Only difference is this is a Pi1 running Node 10.15.0, as is the Pi3, the others are running Node 8.12.0.
The code in the boxes and the line number are all on one line, even in a fresh function node.


#11

Just listened to the changes in the video (great way of doing that BTW) - a lot of stuff in there that sounds really useful - well done for all your efforts on this release - and to that Dave person as well :slight_smile:


#12

I LOVE the export/import of flows!!!! (macOS 10.13.6)


#13

I'm seeing the same issue in the function nodes

And in the Change node jsonata test area


#14

which browser ? which OS is the browser running on ?


#15

I on macOS using Safari and see it in Chrome

In addition I just noticed that the Change node looses it name in the icon
55%20PM

UPDATE: Odd...I deleted that change node and added another and it works fine, can't recreate it...yet...


#16

Can you check a) menu - settings
image
and b) the node config menu - appearance tab
image
Another new feature of 0.20 is to be able to shrink the nodes (no labels) if you want to... either for all newly added nodes - or individually on demand. But Of course all existing nodes should be as they were - and the global default should be to show names (as it was).


#17

I'm using Firefox on Windows but I get the same issue with Chrome.,


#18

Here is menu settings:
35%20PM
and the node Appearance - but I deleted the node and can't seem to make it hapen again
50%20PM

I've noticed where ever you can enter multi lines of text they get written over each other. This happens in the new description area for nodes, in the function node, in the jsonata test area, both the template and ui-template nodes too.


#19

Did you ever upgrade to any of the 0.20.0 beta releases, or is this the first time you've tried 0.20? Trying to establish if this is something that has happened between the last beta and the final release, or something that could have been lurking for longer.

There are now three reports of it - so something is going on. Just not sure what, given its only three reports.


#20

Mine was a straight update from 0.19.6 to 0.20.0, no betas, must be getting old :slight_smile: