Node-RED Beablebone Black won't control gpio

I have a Beaglebone Black that came with Node-Red installed and would initially control the gpoi. I tested it with the USR3 LED. I got the latest distro from the Beaglebone web site and reflashed. Node-RED is installed and runs but I can no longer control gpio. The Beaglebone Node is no longer in the Pallet. I tried installing it from the Pallet Manager and it looks like it is installing but it never does. I tried using the jonny5 Node with the Beaglebone Black io plugin with no success. I have tried every combination of payload injection and pin designation I can think of but nothing works. I have tried installing the Beaglebone Node from the command line using npm but it fails every time I try it. I have also tried tried directly controlling the gpio pins to turn on a LED. I can do it form the command line and form Python but not from Node-Red. Any suggestions?

Good spot... being looked at.

Well I've been fighting with this all day and I finally have success. There is a lot of misleading information out there that is somewhat contradictory. Googlers be ware! I did find a very short and concise page for imaging info and installation:


It appears that the Beaglebone Node that is extremely easy to use is built on the no longer supported octalbonescript and is "not recommended for future use." I'm still going to attempt a manual install (just can't resist breaking something that's working). Using the Johnny5 Node:
Select BeagleBone Black for IO plugin
In Pin enter P8_8 (or whatever pin you're connected to)
for testing I used an inject block with a boolean true as a payload and a blank string as a topic
I set up a similar one for false.
once that was working I added a MQTT in block and now I can toggle the LED on and off from my Android phone. I'm running Mosquitto on my Linux box for a broker. Port forwarding 1883 on my router and I can control it from almost anywhere (we get crappy cell coverage out here in the boonies). I ended up using an alpha release Debian from the Beaglebone site:

Image:
buster-iot - bone-debian-10.5-iot-armhf-2020-08-25-4gb.img.xz
So, that's how I spent my day. I hope this is useful information. Now I'm going to make myself a well deserved margarita!

Yes - somewhere along the line they have messed up the main repo so 1) the node-red user that is used to run Node-RED got removed from the gpio group - and 2) a lot of the gpio pins got reclassified as not gpio so couldn't be accessed. They are busy sorting it out. A new official build should be out soon (probably next week).