Node-Red connection issues

Hello guys i really need help setting up Pilz system for automatic messages.

We are trying to set the system up so it delivers messages trough GSM module. So far GSM module it self works if we send test message it arrives to targets phone. Issue comes when we try to send message trough Node-red [We are using Rev Pi Core 3]. We have solved most of the errors but were stuck at the MQTT and we have... ( virtually tried everything i could think of to connect to it but its just stuck at connecting).

Code - (password - nr )

The code it's self had been used from an Video from YouTube but changed based onto the needs of the module that we have, there had been an few issues with the port it self that the GSM suppose to communicate with, based onto the findings this suppose to be the right flow for this type of project, as well trying to get an physical button input to trigger a message had not been responding well towards this flow.

If you need more information about hardware or anything else just ask in comments.
Please help us out connect it.

from flows I think mqtt server cannot be connected. You should make a simple send-receive mqtt flow to see if mqtt work or not.

Show us the settings for the mqtt config node. The easiest way may be to select the node, Export it to the clipboard and paste it here. See this post for how to do that.

[Edit] I see you have posted the flow to an external site. For future reference it is easier to post it here. As zenofmud has pointed out, you have specified as the MQTT server. Are you running and MQTT server there?

  1. how are you send things to the GSM module? via mQTT or the serial port?

  2. it looks like you have the MQTT broker at - is working in other flows/devices?

The most easiest way is isolating issue for debug. Forget red node and test mqtt from browser like this tool for chrome

If it doesnot work then not a red node problem but mqtt setting

We have tried to send it via serial port, but we supposed to have connection to mqtt via gsm module (This is our first time working with this type of hardware and software so were just trying to figure this out) GSM module works were using Teletonika and message is being delivered perfectly) We have tried so many ports but the issue still persists.

Let's talk MQTT for a moment. Is the gsm module suppose to have an MQTT broker or is it just sending MQTT messages to a (1) predefined broker or(2) a broker you can configure?

We are using Teltonika RUT955 H7V20, Im going to be completely honest with you we are not completely sure. We are learning while setting it up, That is our task.

Do you have a broker?

Installed on the RPI? installed somewhere else? Using a public broker?

In essence, there needs to be a broker and the RPI needs to be able to connect to it.

Additionally, your clients also need to be able to connect the broker.

As I see it, you could install a broker on the RPI and open the necessary ports on the GSM module.

so how do you actually send the test messages?
what is the process and hardware used to get the msg to the GSM to be sent?

We are using TELRONIKA Pre instaled software.

and that works perfectly

These are options for MQTT From Teltonika.

That shows it apparently running on port 88

But your screenshot of node-RED shows you having selected port 161.

Rather than trying random ports, have you tried following the instructions on how to set up their MQTT broker?

You do also understand that the broker won't automatically send on an MQTT message? MQTT works by publishing to the broker and others subscribing to topics on the broker.

From my very brief look at the manual, it seems that the MQTT is being used so you can get info about the router. You should lookout the manual to see how you can send messages thru the router

You should also dertrmine if the device cansend SMS messages ther than router status. You might want to contact the MFG to find out that info.

That's the issue the device arrived without any paperwork then some advertisement pieces, Other then that we have tried to figure out each step on our own. I already tried port 88 from multiple IP addresses doesn't do much good. question

(creator of the device doesn't respond to emails as-well so we just trying to figure this out)

(IMAGE)These are few settings i can change if i enable "Bridge" . Issue for us is there are so much settings and options to enable and disable that its extremely hard to figure out whats at fault especially when we are doing something like this for the first time.

Seems like we have enabled MQTT and it should be available to connect to via SIM card which is activated and fully able to call send messages and access data.

did you try a google search using something like 'TELRONIKA manual'?