When I "Deploy" my Node-RED flow the modbustcp-read nodes don't reconnect.
They show "Initiating...." and then after about 2 minutes they show "Disconnected" but they never reconnect.

I am using a King Pigeon M230T 4 Analog input module.
The hardware device continues to show the "Link" lamp active.

If I reboot the PC it all starts up nicely.
If I node-red-stop, then node-red-start, it all starts up nicely.
If I disconnect then reconnect power to my hardware device while the modbustcp-read nodes show "Disconnected", it starts reading in about 3 seconds

If I disconnect then reconnect power to my hardware while the modbustcp-read nodes show "Initiating..." the status will eventually change to show "Disconnected" but never starts reading.

I have the Modbus reconnect time set to 3 seconds, but changing this doesn't seem to affect the fault sequence.

I have found that having different Poll Rates for read nodes causes another reason for the system not to reconnect.

Why does stop then start (and reboot) work, where "Deploy" doesn't?
Why does the "Initiating..." status stop it from reconnecting?
Why when "Initiating..." does it take so long to decide it is "Disconnected" but then still not reconnect?

This situation makes working on even a simple flow very tedious.

Any thoughts please?
Thank you

the problem most likely lies with how the author has written the node and how he handles disconnections. This is some good info you have provided however you should post it as an issue on the GitHub repository for him to see and action.
That way (assuming the project is active and the author considers it to be a real problem & fixes it), everyone benefits. Win win.

You could always clone the project, make some fixes and do a pull request for the author? Again, win win

1 Like


I had similar situation with modbus rtu modules. The connection was PC->MOXA modbus tcp/ip - RTU ->Device.

It was acting similar to what you were describing. In my case problem was with serial settings: parity and stop bits.

Do you have other ways to check if your King Pigeon M230T 4 Analog input module replies to modbus messages? For me was first tool before finding node-red

I try to connect my king pigeon S266 cellular device, do you have any information that could help me?

I have not tried to connect a King Pigeon S266 to Node-Red.
I have looked up the device manual and it indicates that it is a "Reserved Function". I am not sure what that means.
It also says to look at the S264 manual got the GPRS protocol.