Node-red core will not install 3.0.0 core

I am trying to upgrade node-red to version 3.0.0 from 2.2.2. But the core does no install.

Stop Node-RED                       ✔
  Remove old version of Node-RED      ✔
  Node option not specified           :   --node14, --node16, or --node18
  Leave existing Node.js              :   v14.10.0   Npm 6.14.8
  Clean npm cache                     -
  Install Node-RED core               ✘   3.0.0 
  Move global nodes to local          -
  Leave existing nodes                -
  Install extra Pi nodes              ✔
  Add shortcut commands               ✔
  Update systemd script               ✔

Try specifying the --node16 flag to update node from v14.10.0 to the current lts version. (But it should only require 14+)

What do the install logs say?

type or paste code here
```***************************************

Started : Tue Jul 26 12:34:41 PM EDT 2022
Running for user henry at /home/henry
Found global nodes:   :

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package nodered

Versions: node:v14.10.0 npm:6.14.8
Now install Node-RED 
sudo: npm: command not found
3.0.0 
Now create basic package.json for the user and move any global nodes
Installing extra nodes: node-red-node-pi-gpio@latest node-red-node-random@latest node-red-node-ping@latest node-red-contrib-play-audio@latest node-red-node-smooth@latest node-red-node-serialport@latest :
npm WARN notsup Unsupported engine for @serialport/bindings-interface@1.2.2: wanted: {"node":"^12.22 || ^14.13 || >=16"} (current: {"node":"14.10.0","npm":"6.14.8"})
npm WARN notsup Not compatible with your version of node/npm: @serialport/bindings-interface@1.2.2
npm WARN notsup Unsupported engine for @serialport/bindings-interface@1.2.1: wanted: {"node":"^12.22 || ^14.13 || >=16"} (current: {"node":"14.10.0","npm":"6.14.8"})
npm WARN notsup Not compatible with your version of node/npm: @serialport/bindings-interface@1.2.1
npm WARN notsup Unsupported engine for @serialport/bindings-interface@1.2.1: wanted: {"node":"^12.22 || ^14.13 || >=16"} (current: {"node":"14.10.0","npm":"6.14.8"})
npm WARN notsup Not compatible with your version of node/npm: @serialport/bindings-interface@1.2.1

+ node-red-node-smooth@0.1.2
+ node-red-node-serialport@1.0.1
+ node-red-node-pi-gpio@2.0.5
+ node-red-node-random@0.4.0
+ node-red-contrib-play-audio@2.5.0
+ node-red-node-ping@0.3.1
updated 6 packages in 4.384s
Now add the shortcut and start/stop/log scripts to the menu
Now add systemd script and configure it for henry:henry @ /home/henry
ln: failed to create symbolic link '/usr/bin/python': File exists
Now add launcher to top bar, add cpu temp example, make sure ping works
adduser: The group `gpio' does not exist.

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
python3-rpi.gpio is already the newest version (0.7.1~a4-1build1).
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Memory  : 4.7G
Started :  Tue Jul 26 12:34:41 PM EDT 2022 
Finished:  Tue Jul 26 12:35:21 PM EDT 2022

So you have Node v14.10.0 but you have nodes that require Node v14.13.0 or higher.