Node red failing to start


I have encountered this issue at least 2 or 3 times now. I am not sure why it happens or how to diagnose the issue? Any help would be appreciated.

7 Jul 11:12:34 - [info] Node-RED version: v1.3.5
7 Jul 11:12:34 - [info] Node.js version: v14.17.0
7 Jul 11:12:34 - [info] Windows_NT 10.0.19042 x64 LE
7 Jul 11:12:36 - [info] Loading palette nodes
7 Jul 11:12:37 - [error] Failed to start server:
7 Jul 11:12:37 - [error] TypeError: Cannot read property 'forEach' of undefined
at Object.addModule (C:\Users\user\AppData\Roaming\npm\node_modules\node-red\node_modules@node-red\registry\lib\registry.js:195:27)
at C:\Users\user\AppData\Roaming\npm\node_modules\node-red\node_modules@node-red\registry\lib\loader.js:153:34



Hi @bceyresy

have you installed any new nodes recently? Or tried to create your own nodes?

Yes I installed a few in fact. Last time this happened I removed the modules from the .nod-red directory in the current user, then also removed the lines corresponding to the modules called in .config.nodes.json but this time it has not solved the issue. I think I got lucky last time.

Please shine some light on it :upside_down_face:

This error is 100% caused by a 'bad' node somewhere.

You don't need to delete .config.nodes.json - that is just a record of what has been found.

Are you sure there isn't left behind in .node-red/node_modules?

Ye I have deleted the last recent 3 I installed and used. It still will not boot.

There are 2 module folders, one in the .node-red & one under AppData\roaming.

Whats the difference between the 2?

Found the bad note. It was cratedb. I Had the same issue with Postgres nodes. I am using Mysql at the moment. is there issues with installng other DBs?

What module name exactly? I'd like to track down nodes that cause this so we can either get them fixed, or remove them from the flow library.

it appeared to be node-red-contrib-cratedb was this instance. I can't remember exactly which postgres node was the issue last time as I installed quite a few together.



@knolleary node-red-contrib-cratedb was last updated over four year ago and in GitHub the author has archived it.

Yes. I looked it up as well.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.