Node-RED google home integration


#125

This works better than I expected. Finally I will get some use out of our Google Home Mini. Let me know if you need any assistance. Would be great to get some more devices types in. Would also love to see this properly released somehow. I'm sure many with me would happily pay a small fee every month to keep it running. If there's anything I can help out with, shot me a message.


#126

New device types will get in as soon as I have some time/need to create them. There is no priority list but there is some progress on thermostat and next one is fan. Maybe open a github issue if you need a specific device (from the list of supported ones) and ideas on how the node should behave.
Releasing it depends on Google as it needs to pass some certification stage and it got delayed with the holidays and so on.
There's no need for monthly fee for now (I guess we'll see how the heroku dyno handles lots of connection but I estimate it will work well with a few hundred active users), however I did add a link for donations so feel free :beers:


#127

I sent you a small payment that hopefully covers some of the costs in the meantime.


#128

Thanks, unfortunately that didn’t resolve it!

I can’t quite figure out why this won’t work...


#129

Can you post the flow json along with an inject node that does work?


#130

Did anything happen to the server recently? I was adding more lights and all of a sudden it stopped working altogether. It says "Connected" in the nodes but when I try to control the lights the Home app says "Not responding".

/edit -- I removed the link to Nora in Home and added it again. First time it timed out, second time it worked and now I can control lights again.


#131

This may happen if you open the link I pm'ed you more than once.
I also noticed and reported (back to Google) the fact that unlink needs 2 tries to work.


#132

Unfortunately not - 02 88 00 01 1b 83 00 01 00 00 00 00 00 00 01 8a 03 is the string, i'm not sure if it needs to be wrapped in " or [ ] or translated to 0x02 0x88 0x00 0x01 etc before it is sent, but nothing seems to work on trial and error, whereas sending 02 88 00 01 1b 83 00 01 00 00 00 00 00 00 01 8a 03 using Packet Sender works every time.

21


#133

Is anyone here running into issues with Node-Red memory usage. I've noticed recently that my Node-Red deployment sometimes is eating up 75% or more of my memory on my Raspberry Pi. I can't directly correlate to when I started using the NORA nodes so don't know for sure if there is a memory link in them but wanted to see if others were noticing similar issues while I try to find ways to track down memory use through the logs.


#134

Makes sense. I definitely did.


#135

My node-red instance uses about 8% of the memory on a RPI3 (10 nora nodes). Are you using the default systemd service to launch node-red? That one uses NODE_OPTIONS=--max_old_space_size=256 so it should trigger the GC around that limit.

Reading the documentation for the buffer input, it says that it needs to be a valid json number array. So no hex number format support. Try this: [2,136,0,1,27,131,0,1,0,0,0,0,0,0,1,138,3]


#136

Tried a quick setup last night, and here are some thoughts...

  • With multiple 'Homes', new devices don't seem to get assigned to any home. You have to manually add them I guess. I just removed the 'Home' I wasn't using and unlinked and relinked NORA. Although probably that isn't required.
  • Didn't need to unlink twice contrary to what @andrei-tatar mentioned above.
  • Scenes don't appear as devices... (duhh... :roll_eyes:)
  • Scenes do appear in Google Assistant settings under Assistant tab -> Home Control
  • Lag between button press and response: 2 - 3 seconds on external network (using a VPN on phone), ~ 1.5 seconds on home wifi.
  • Newly added devices turn up in Google Home automagically after the first setup

Possible bugs(?):

  • If I set a light on in Home app, and then turn it off through Node-RED, it doesn't turn off in Home app unless I refresh the view by going onto some other device.
  • If the brightness of a light is changed in Node-RED, it will change the actual device brightness, but Home app doesn't reflect the changed brightness even after turning light on/off couple of times in the app.

My Raspberry Pi RAM usage seems to hover around 80MB and I can't see much (if any) difference with (6) NORA nodes installed and running vs. previously.
I am monitoring the RAM usage with free | grep Mem | awk '{print $3/1024}' I am not entirely sure if the Used field is the one I am supposed to monitor.


#138

@andrei-tatar Can't PM you yet.
It would be great if you could add me to the test group for NORA
Seems very cool, looking forward to tinker with it

email: tamirtw@gmail.com


#139

Mine start's out in th 7% range but four days in I'm setting at 31% and the other day (didn't look at the uptime) I was at 85% so definitely looks like a memory leak some place. I unfortunately made a bunch of changes at the same time (added NORA [34 nodes] and Cast nodes) and moved from a root-based to a user based install. I use PM2 to run Node-Red since it supposedly improves performance. I haven't had these issues in the past but will give it a try adding the max old space option to the runtime and see if that helps.

Thanks. htop is a pretty useful tool for monitoring usage.


#140

Hi Andrei,
I would like to use this wonderful integration as well :wink:
Can you PM me as well?

thanks!
Gert


#141

My RPi RAM usage is still solid around 80MB (18% used by NR), two days after installing and running NORA, so there doesn't seem to be any memory leak here. Although I am using only light and switch nodes.

Thanks! Never knew it was so configurable! :smile:

NoRa is running like a breeze! Now I just wish I could change the wake word to something other than 'Hey Google!' :unamused:


#142

It looks awsome.. sending my gmail account by PM.. thanks!

Edit: it is not possible to send PM right after registration.. So can you add my account ales.prihoda@gmail.com to testing user list? Thanks'


#143

Just published 0.0.20 with support for thermostat node.


#144

Hi @andrei-tatar I am really keen to test out NORA if you could kindly PM me that would be wonderfull.

Cheers


#145

Hello @andrei-tatar, I'm stated couple moths ago a home automation project, today I already use IFTTT and node-red. But i looking for a new and easier solution to integrate google home.

I would like to test NORA, can you send me a PM, there is no Message Icon in you profile.