Node-red-node-pi-gpio out stopped working

Suddenly 2 of my rasberry stopped working the same problem. The node rpi-gpio out is grey and disappered from the node collection. In the flow is says "Unknown: rpi-gpio out".

I've upgraded Raspian to latest. Removed from palette the node-red-node-pi-gpio. Restarted and reinstalled it. But no luck. My Rasperrys is one pi4 and one pi zero W. I believe it happend on the 6/12 if it's any lead.

Best Regards Magnus

Did you do anything to the two pis (or anything else in your network) at the time it failed?

None. that should do anything with this.

I saw not when checking more closely on pi zero W that also gpio in is missing. That pi runs version 1.2.3 of node-red-node-pi-gpio.

Maybe they should not be anything to do with this, but obviously something happened. So what did you do?

Have you tried re-booting? Also try clearing the cache in the browser (using the browser menus to clear it).

The only thing I've done is working on a bash script on another machine totaly irrelevant. The pi4 is after i detected the problem upgraded to latest Raspian and reinstalled the node. Nothing else have I done. And about cache in browser is also tested. Still problem.

For it to happen on two pis at the same time without you doing anything to the pis means that is something external to the pis, or it is a most remarkable co-incidence.

Open the browser console and see if you see any errors when you refresh the page

Also stop node red and start it again in a terminal and post the output here.

Starting as a systemd service.

8 Dec 21:56:49 - [info]

Welcome to Node-RED


8 Dec 21:56:49 - [info] Node-RED version: v1.3.4

8 Dec 21:56:49 - [info] Node.js version: v10.24.0

8 Dec 21:56:49 - [info] Linux 5.10.63-v7l+ arm LE

8 Dec 21:56:51 - [info] Loading palette nodes

8 Dec 21:56:53 - [info] Settings file : /home/pi/.node-red/settings.js

8 Dec 21:56:53 - [info] Context store : 'default' [module=memory]

8 Dec 21:56:53 - [info] User directory : /home/pi/.node-red

8 Dec 21:56:53 - [warn] Projects disabled : editorTheme.projects.enabled=false

8 Dec 21:56:53 - [info] Flows file : /home/pi/.node-red/flows_honshus.json

(node:2245) UnhandledPromiseRejectionWarning: Error: ENOENT: no such file or directory, scandir '/usr/lib/node_modules/node-red/node_modules/@node-red/nodes/examples'

(node:2245) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)

(node:2245) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

8 Dec 21:56:53 - [warn]


Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials

file will not be recoverable, you will have to delete it and re-enter

your credentials.

You should set your own key using the 'credentialSecret' option in

your settings file. Node-RED will then re-encrypt your credentials

file using your chosen key the next time you deploy a change.


8 Dec 21:56:53 - [info] Server now running at

8 Dec 21:56:53 - [info] Starting flows

8 Dec 21:56:54 - [info] [Bme280:BME280] Initializing on bus1 addr:119

8 Dec 21:56:54 - [info] Started flows

8 Dec 21:56:55 - [info] [mqtt-broker:server] Connected to broker: mqtt://

Found BMx280 chip ID 0x60 on bus i2c-1, address 0x77

8 Dec 21:56:55 - [info] [BME280:BME280] Sensor BME280 initialized.

I don't know if it's any help but both my pi:s respond when I write command
gpio readall with

Oops - unable to determine board type... model: 17

Check you are using the latest versions of all the pi s/w packages
sudo apt update
sudo apt full-upgrade

Then reboot

Check your settings file for the RasPi. (raspi-config) and make sure the GPIO setting is still active.

Done, check on that. Did that before asking for help.

I'm not sure really if I did right here on this tip.
If not point me in right direction please

cat config.txt | grep -v ^#



dtoverlay=w1-gpio,gpiopin=4 pullup=0

Did you install using the recommended script ? You seem to have be using node10 which is no longer supported, so is that deliberate?

I do think you are on something here. I tried the install script earlier today. It detected that I ran node10 and let me choose what to do. I don't remember what the script said but I thought i've done correct. The script downloaded I believe 1,4Gb and needed a reboot. Therefore I thought thats done. What to do next?

When I try the script now it says:

Running Node-RED install for user pi at /home/pi on raspbian

Nodejs 10 is no longer supported.
You can update to the latest Node-RED 1.x version by adding --nodered-version="1.3.5"
to that install command. If in doubt this is the safer option.

Or you can force an install of node 12 or 14 by using the --node12, --node14 or --node16 parameter
However doing so may break some nodes that may need re-installing manually.
Generally it is recommended to upgrade all nodes to their latest versions before upgrading.

Please backup your installation and flows before upgrading.

Exiting now.

Do you have any critical non standard nodes (iE ones for some specific hardware or device?). If not I would go for the --node14 option

I ran the install script again with --node14 option and it worked fine. After that I had to edit the settings.js to set the uiHost: ""
Now it's up and running using chrome browser but for some reason it won't work with my old safari, but thats ok.

Many thanks for all help
Best Regards Magnus

It isn't normally necessary to do that, did something not work without it? Leaving it unset should allow access via localhost or via the ip address.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.