Node-red-node-pibrella: missing RPi.GPIO python library

I know that the pibrella board is not sold anymore, but I still have one and just needed the buzzer for a quick test.

In the node-red-node-pibrella doc I can read the following:

## Pre-reqs

Requires the RPi.PIO python library version 0.5.8 (or better) in order to work. See the [RPi.GPIO site]( for mode details.

sudo apt-get -y install python-rpi.gpio

but my Raspian Bullseye tells me:

Package python-rpi.gpio is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Nevertheless I installed the node, and the Palette says:

Warning : Can't find RPi.GPIO python library.

How can I install a RPi.GPIO python library for Bullseye?

That node is liable to very old and prob rely on Python2
[edit] I just looked at the pibrella node and it is maintained by Nick and Dave so maybe it might get updated to work nowadays[/edit]

Workaround could be to just use the standard Pi output node to make it beep

This works for me on one of mine

It's working!

However, I have to use a fixed frequency. Can I send the frequency with the payload, so that I can change the frequency by script or via slider?

I don't think the basic node allows that unfortunately :frowning:

Just tried the pibrella node out on my bullseye and I get the same error message in the console as you which is strange as RPi.GPIO is definitely installed

I looked at code in the node and it's checking for old python RPi.GPIO library

I changed line15 in
[edit - corrected file name :slight_smile: ]

if (!fs.existsSync("/usr/share/doc/python3-rpi.gpio")) {

and it now works for me

I'll issue a PR for it


You changed line 15 in the .js file in this directory.
Is it always 38-rpi-pibrella.js?

After installing the node again and changing the above check for the gpio file, I can use the pibrella node.
Thank you!!

1 Like

Sorry to have missed out he vital bit of the filename :slight_smile:

My PR has been accepted and merged so the fix should be available in the next NR release :slight_smile:

1 Like

It’s available now

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.