Node Red sleeping on OrangePi

Hello.

Debian + Mosqitto + Node-Red + PM2 is installed on OrangePi and everything works well, MQTT handles Old, Node-Red draws graphs. But it’s worth leaving it overnight and connecting to the Web interface the next day as all the data is lost, OrangePi on the network displays the router as an active device, but it seems as if it fell asleep, because after treatment it starts to work, receive data and build charts. I tried to disable sleep mode with the line: sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target but did not help. Does anyone know how to overcome this?

Hi
Unfortunately, I don't think many people here use an OrangePi.

You might get more help on an OrangePi forum as it seems to be specific to that device

My Orange Pis with armbian (4 * OPi PC) have been running rock solid since ~ 2017. If you're running any other distro I'd suggest try armbian first. Buster minimal to begin with: https://www.armbian.com/download/?tx_maker=xunlong

How much RAM do you have in that OPi?

I’m using Debian last update. I take it from Orangepi.org - Downloads. OrangePi Zero 512Mb. But it's all working without problem. I’m install node-red, npm, pm2, Mosquitto and dashboard in node-red. And when I’m use it - its work. It’s working after rebooting. BUT if I’m not connect about 6 hours or try connect on next day - Node Red is not online, ui not online. I’m try turn off power save mode - sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target and setterm powersave off but it’s not help me.
Maybe you know what is the problem?

A friend of mine has an OPi Zero 256MB with node-red running 24/7 with no problems. He's using armbian buster minimal "headless" (a.k.a. buster server). Me too, but my OPi (PC) has 1GB. Again, if I were you I'd try that, it works. Armbian is the best distro for all these chinese SBCs.

https://www.armbian.com/download/?tx_maker=xunlong

1 Like

Thank you. I try Armbian