NodeRed authentication behind Nginx-proxy

Hi there,

I'm trying to setup an IFTTT integration with NodeRed, but i'm running into trouble with authentication.

First of all, I'm running nodered with adminAuth enabled. Then i've setup nginx proxy like this:

server {
        listen 443 ssl;
        listen [::]:443 ssl;
        server_name my_hostname;
        proxy_http_version  1.1;
        proxy_cache_bypass  $http_upgrade;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";

        proxy_set_header Host $host;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Proto $scheme;
        proxy_set_header X-Forwarded-Host $host;
        proxy_set_header X-Forwarded-Port $server_port;
        location = /robots.txt {
                add_header  Content-Type  text/plain;
                return 200 "User-agent: *\nDisallow: /\n";
        location / {
        ssl_certificate /docker/acme/my_hostname/fullchain.cer;
        ssl_certificate_key /docker/acme/my_hostname/;
        ssl_session_timeout 30m;
        ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
        ssl_session_cache shared:SSL:10m;
        ssl_dhparam /docker/acme/my_hostname/dhparams.pem;
        ssl_prefer_server_ciphers on;
        ssl_buffer_size 8k;
        #ssl_stapling on;
        #ssl_stapling_verify on;
        add_header Strict-Transport-Security max-age=31536000;
        access_log /var/log/nginx/dev_ssl_access.log;
        error_log /var/log/nginx/dev_ssl_error.log;
    #-------- END SSL config -------##

        location /ifttt {
          auth_basic "Restricted";
          auth_basic_user_file conf.d/htpasswd;
          proxy_set_header Authorization "";

When i access https://my_hostname/ifttt from outside my LAN, is asks for the basic authentication and it's ok. But then it shows the NodeRed login screen. How can i bypass that login screen if i already authenticated on Nginx proxy? Can i use the access_token somehow?

It sounds like you have adminAuth enabled in the settings.js file. If you comment it out and restart Node-RED then you wont see the admin auth challenge.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.