Npm ENETUNREACH - ERROR

Nice i wanted to install

node-red-contrib-ui-svg

A Node-RED widget node to show interactive SVG (vector graphics) in the dashboard

But it got the error see below.
I run node red on a raspberry. I thin it has a fixed IP...
Before some time it worked.
But now the npm makes trouble :frowning:


-----------------------------------------------------------
2020-10-05T19:57:17.272Z installieren : node-red-contrib-ui-svg 2.0.3

2020-10-05T19:57:29.429Z npm install --no-audit --no-update-notifier --save --save-prefix="~" --production node-red-contrib-ui-svg@2.0.3
2020-10-05T19:57:45.460Z [err] npm
2020-10-05T19:57:45.462Z [err]  
2020-10-05T19:57:45.462Z [err] ERR! code ENETUNREACH
2020-10-05T19:57:45.464Z [err] npm
2020-10-05T19:57:45.465Z [err]  ERR! 
2020-10-05T19:57:45.465Z [err] errno ENETUNREACH
2020-10-05T19:57:45.494Z [err] npm
2020-10-05T19:57:45.495Z [err]  ERR!
2020-10-05T19:57:45.495Z [err]  request to https://registry.npmjs.org/node-red-contrib-ui-svg failed, reason: connect ENETUNREACH 104.16.20.35:443 - Local (0.0.0.0:0)
2020-10-05T19:57:45.529Z [err] 
2020-10-05T19:57:45.530Z [err] npm ERR!
2020-10-05T19:57:45.530Z [err]  A complete log of this run can be found in:
2020-10-05T19:57:45.530Z [err] npm ERR!
2020-10-05T19:57:45.530Z [err]      /home/pi/.npm/_logs/2020-10-05T19_57_45_502Z-debug.log
2020-10-05T19:57:45.566Z rc=

Here is the npm config?

npm config list --json
{
  "json": true,
  "user-agent": "npm/6.14.8 node/v10.15.2 linux arm",
  "metrics-registry": "https://registry.npmjs.org/",
  "scope": "",
  "access": null,
  "allow-same-version": false,
  "always-auth": false,
  "also": null,
  "audit": true,
  "audit-level": "low",
  "auth-type": "legacy",
  "before": null,
  "bin-links": true,
  "browser": null,
  "ca": null,
  "cache": "/home/pi/.npm",
  "cache-lock-stale": 60000,
  "cache-lock-retries": 10,
  "cache-lock-wait": 10000,
  "cache-max": null,
  "cache-min": 10,
  "cert": null,
  "cidr": null,
  "color": true,
  "depth": null,
  "description": true,
  "dev": false,
  "dry-run": false,
  "editor": "vi",
  "engine-strict": false,
  "force": false,
  "format-package-lock": true,
  "fund": true,
  "fetch-retries": 2,
  "fetch-retry-factor": 10,
  "fetch-retry-mintimeout": 10000,
  "fetch-retry-maxtimeout": 60000,
  "git": "git",
  "git-tag-version": true,
  "commit-hooks": true,
  "global": false,
  "globalconfig": "/usr/etc/npmrc",
  "global-style": false,
  "group": 1000,
  "ham-it-up": false,
  "heading": "npm",
  "if-present": false,
  "ignore-prepublish": false,
  "ignore-scripts": false,
  "init-module": "/home/pi/.npm-init.js",
  "init-author-name": "",
  "init-author-email": "",
  "init-author-url": "",
  "init-version": "1.0.0",
  "init-license": "ISC",
  "key": null,
  "legacy-bundling": false,
  "link": false,
  "loglevel": "notice",
  "logs-max": 10,
  "long": false,
  "maxsockets": 50,
  "message": "%s",
  "node-options": null,
  "node-version": "10.15.2",
  "offline": false,
  "onload-script": null,
  "only": null,
  "optional": true,
  "otp": null,
  "package-lock": true,
  "package-lock-only": false,
  "parseable": false,
  "prefer-offline": false,
  "prefer-online": false,
  "prefix": "/usr",
  "preid": "",
  "production": false,
  "progress": true,
  "proxy": null,
  "https-proxy": null,
  "noproxy": null,
  "read-only": false,
  "rebuild-bundle": true,
  "registry": "https://registry.npmjs.org/",
  "rollback": true,
  "save": true,
  "save-bundle": false,
  "save-dev": false,
  "save-exact": false,
  "save-optional": false,
  "save-prefix": "^",
  "save-prod": false,
  "script-shell": null,
  "scripts-prepend-node-path": "warn-only",
  "searchopts": "",
  "searchexclude": null,
  "searchlimit": 20,
  "searchstaleness": 900,
  "send-metrics": false,
  "shell": "/bin/bash",
  "shrinkwrap": true,
  "sign-git-commit": false,
  "sign-git-tag": false,
  "sso-poll-frequency": 500,
  "sso-type": "oauth",
  "strict-ssl": true,
  "tag": "latest",
  "tag-version-prefix": "v",
  "timing": false,
  "tmp": "/tmp",
  "unicode": true,
  "unsafe-perm": true,
  "update-notifier": true,
  "usage": false,
  "user": 0,
  "userconfig": "/home/pi/.npmrc",
  "umask": 18,
  "version": false,
  "versions": false,
  "viewer": "man",
  "globalignorefile": "/usr/etc/npmignore"
}

Has someone any idea?
Thank you :slight_smile:

Either NPMJS is down or your Internet connection is down!

More likely the former of course :smiley:

This has happened quite a bit I note over the last few weeks.

Than you for your answer.
I can ping google.com with my raspberry.
So my Internet connect may be ok...

Ok : traceroute registry.npmjs.org doesnt work!

what works:
traceroute to localhost (127.0.0.1), 30 hops max, 60 byte packets
1 localhost (127.0.0.1) 0.116 ms 0.039 ms 0.039 ms

root@raspberrypi:/home/pi# traceroute google.de
traceroute to google.de (172.217.18.99), 30 hops max, 60 byte packets
connect: Network is unreachable

OMG !!!!
YOU HAVE TO ADD YOUR STANDARDGATEWAY TO YOUR CONFIG.
Omg

route add default gw HEREYOURIP!!!!

Is this a standard raspbian setup? You shouldn't need to do that. If you are using DHCP it should happen automatically, if you have configured a fixed ip then in /etc/dhcpcd.conf you should have something like

interface eth0
static ip_address=192.168.1.73/24
static routers=192.168.1.1
static domain_name_servers=8.8.8.8 8.8.4.4

Wow! even for me in the UK, it is only 10 hops to google.de