OPC UA Client reconnects frequently

Hi,

I'm using many OPC UA Clients within a flow to connect to many different OPC UA Servers to check if they are still online (Data is fetched from an other Client. Servers have other problems that they fail sometimes, therefore the check with Node-RED). It worked until a few weeks ago as expected. The Client connects and a READ request of one nodeID is sent. Then every 15s the same READ request is sent again. The status of the client is always "active reading".
Then every Client showed the same strange behavior, although nothing was updated or changed in my knowledge. Every client was reconnecting every ~60s. The status stays at "connected re-established". To stop the reading, the inject node was disabled but the reconnects still happened, even more often at ~4x per second. This is a tcpdump screenshot:

On the server there were logged creating new secureChannels in the same rate:
image

Even after disabling the clients with deploy and then also the endpoint config node with a deploy, this still happened. Only a restart of the podman container stopped this. Activating the nodes again startet the behavior again. Activating the inject nodes again slowed this down to once every minute.

The trace log showed this:

I have 4 containers running:
image
Red is where the above happens.
2 of the 0.2.318 or 0.2.320 were updated after I noticed this, but I don't know which version I had before.

I noticed it because an other OPC UA client couldn't connect anymore, then I saw this what I wrote above.

So my question is, what can cause this behavior? Is this a known bug that I didn't manage to find online? What can I do to investigate it deeper?
I certainly sure it's not my mistake because it worked for a longer time before in this configuration.

Thanks and best regards,
haph

Check first that both computers are at same time

They are at the same time, all are synchronized with the same time server. I had the time error before and it looks different than the current error.

I will publish new version today/later this week, please re-test with it.

We'll set up a new Node-RED server in a week or two. Once the server is up, I'll install node.js, Node-RED and Node-RED OPC UA in the newest version for every instance.
Then I'll report back.

Thank you!!

So just tested the first OPC UA Client and it seems solved. I'll let this thread open for a week and close it, when no error is detected within this time.