Package install failed

I have dependency record in my project,

    "@opensearch-project/opensearch": "2.8.0"

When I click install from ui it fails with error, logs show this:

2024-06-14T06:33:43.698Z Install : @opensearch-project/opensearch 2.8.0

2024-06-14T06:33:43.965Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --omit=dev --engine-strict @opensearch-project/opensearch@2.8.0
2024-06-14T06:33:45.306Z [out] 
2024-06-14T06:33:45.306Z [out] up to date in 1s
2024-06-14T06:33:45.314Z rc=0

If I run it with the same command from /data directory it will install without any errors.

I checked in both 3.1.9 and 4.0.0-beta4 using docker images *-latest-18

also in 4.0 this package not marked installed in dependency mananger even if I install it manualy.

There is no error there. It says it is already installed.

What is this dependency manager?

this one

opensearch is installed in npm btw, it was marked "installed" in 3.1.9, but with 4.0.0 it not want to be marked such

if I click install I get

and this log:

OK, that is Manage Palette.

Now that you have shown us the problem (Manage palette thinks there is an error, whereas there is no error shown in the log) I will see if I can replicate the problem.

No, it is not "manage palette", it is here

Manage pallete is complete different menu, it is legal to call my screen Dependency manager and I think completely wrong to call it "Manage pallete" because it has own menu item. :slight_smile:
Sorry, seems I forget to mention project in first message. I think I will add more screenshots if I init topic again :slight_smile:

Yes, you are right, it is not Manage Palette, what it should be called I don't know as I don't use projects. I have tried to replicate the problem in a non-projects environment but I don't see any problem there, so I think you will need someone who uses projects and NR 4 to have a look.

NR 3.1.9 is the same, only difference that sometime it marked openserch as installed after manual npm install --save