PCF8574P Chip via i2C

I have several PCF8574P interface chips, this is an i2c to 8 I/O pins. You can use them for input or output and I have had great success with them when I was programming in python.

I wanted to use them with Node Red, but I cannot seem to get a functional addition to the palette. I found: node-red-contrib-pcf8574-cluster but when I attempt to load it, it fails. I've tried by doing both the direct install and via the terminal... just doesn't work.

These are not part of an LCD, so those routines that send text won't help... I just want to be able to specify the address and then ideally... for the pins...

  1. Read the whole 8-bits.
  2. Write the whole 8-bits.
  3. Read any single bit.
  4. Write any single bit.

Unfortunately... I don't know how to turn my python into a palette object. Can anyone out there assist me??

If there is a generic i2C that you specify the chip parameters to... that would also be helpful and I could start there as I also use these..

ADS1115 and/or ADS1015 A/D converter -> Found a module that works exclusively for that chip... and I was able to connect it to an SVG graphic gauge... so I have the ability to use that series.

MCP23017 a 16-bit I/O chip. -> I found an LCD object... but it appears that it can also address pins directly... so I'll experiment with that as well.

Obviously a generic i2c would be helpful as in theory I could use any chip.


Did you look at these?

This one looked promising... failed to load.
# node-red-contrib-i2c

It looks like it would have done exactly want I wanted too. :frowning:

Check permissions - also check out Peter Scargills blog - i am pretty sure a while ago there was lots on there about issues with i2c and RPi (and clones) and issues with permissions etc


What is the error? Did you raise an issue on the repo - could be a bug the Dev can fix.

Still new here... not sure what a REPO is nor how to raise an issue.

The Raspberry Pi is a fresh install on a microSD card, i2c, serial, 1-wire, have been enabled. I successfully installed other palette objects, so that's not the problem.

As for the error... here is the ERROR LOG.
Error-Log.txt (49.0 KB)

I hope that helps.

Maybe this may help?

I have tried to install the I2C node as well, read the fails to install directions and never did get it in. Finally came to the decision if it was that much trouble I didn't want to use it as my application is fairly important and if that pi failed didn't want to jump through all the hoops to get another one running. And no didn't raise an issue as I went another direction.

I maybe going the same direction also!

It looks like I will need to learn (or try to) how to create a palette object from some python code that I have which works. I was using wxGlade and/or an editor and Glade to write code before I discovered Node Red... so I have communicated with the chips.

I guess my next step is to see to to create a palette object.

If someone gets one working... please do let me know.


Or maybe post an issue/question on the repo? It would be good for the community if that node was fixed.


Sorry to be such a nube... where is the repo?
On the forum? from the Node page? Someplace else?


I don't see any reference to "REPO" other than your comment.

I do see the author: https://flows.nodered.org/user/dave.kasparov

I will see if there is a message link or email.

Thanks for the help.

REPO = repository = the GitHub repository (https://github.com/david-kasparov/node-red-contrib-pcf8574-cluster)

1 Like


My apologies for not being clearer. As @zenofmud said - repo = repository.

Tried to raise issue and the site wouldn't let me log in or create a new account. Did read through the issues list though and it seems the install fail was raised a couple of times and his solution was to check a directory and if these folders weren't there create them, blah blah blah. Basically, their answer to install failed was to write out the details listed in the install fails snippet and let it go at that. Doesn't seem like they were interested in fixing the code just providing work arounds. I will try to raise the issue again but it feels like they are done with the node. Talking about the contrib-i2c-node here as there seems to be two different nodes being discussed.

Now that I know where to go... I was able to open a ticket...

So we will see if a fix comes from it.

1 Like

You raised the issue on a different node than I was looking at. But that's ok.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.