Permissions Error for Advanced Logger

I feel like I am missing something very simple here and it is infuriating, I must be an idiot.

I installed node-red on my raspberry pi using the instructions at Running on Raspberry Pi : Node-RED

Everything is setup and running, I create a flow which uses the advanced logger (node-red-contrib-advance-logger)

But no matter where I tell node-red to save this file I always get "Error: EACCES: permission denied"

I am currently trying /var/local/logs.json (The file is there)

I have set chown 1000 on that folder based on a reccomendation from another thread.
I also enabled the contextStorage module:"localfilesystem" in the settings.json file.

Welcome to the forum @multicm

As an experiment, try saving it to the node red users folder, usually /home/pi

Unfortunately I get the same error

I see the node has not been updated for 4 years, it may be that it does not work with current versions of nodejs. You could try submitting an issue on the node's github page but I suspect it is no longer supported.

Okay I will look into that. What node do you use to save log files? I am just trying to write data from http request to a file.


You could use the File node from the core node red. With that you can overwrite a file or add to the end.

or node-red-contrib-flogger (no need to worry about managing files)

Using the file node gives the same error as the other logger node.

Stop node red and start it again in a terminal, then trigger the error. Post the terminal output from start to the error. Also show us how you have configured the file node.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.