Pi GPIO node econnrefused

node red on because it is setup with into container.
did the sudo pi gpiod into terminal
set the port at 1880 into the gpiod output node
I tried the default port at 8888 not better
First time I hit the inject button I get the error
when I hit again no error anymore but nothing happens on the pin which is a simple led plugged in
I'm stuck.
If someone has someting for me please thank you!
did the command
netstat -an | grep LISTEN | grep -v LISTENING
tcp6 0 0 :::1883 :::* LISTEN
tcp6 0 0 :::9000 :::* LISTEN
tcp6 0 0 :::9001 :::* LISTEN
tcp6 0 0 :::2003 :::* LISTEN
tcp6 0 0 :::8083 :::* LISTEN
tcp6 0 0 :::53 :::* LISTEN
tcp6 0 0 :::8086 :::* LISTEN
tcp6 0 0 :::8888 :::* LISTEN
tcp6 0 0 :::1880 :::* LISTEN
tcp6 0 0 :::3000 :::* LISTEN
tcp6 0 0 :::8089 :::* LISTE

When you started your container did you allow port 8888 to be mapped from inside to outside ?

Hi Jay,
This is a good question.
I did the install via Graham Garner IoTstack github setup.
I should know but I don't sorry.
That is what happens when you build on something you did not build yourself...
Would you know how to verify that ?

I also did the
npm install node-red-node-pi-gpiod

Are you using a container for a reason? If not then I suggest you instead use the install script from the node-red docs

Ok I changed to my raspbian regular setup and it worked. sorry about that. It must be a container knowledge issue.
Thank you!

1 Like

One of the reasons for using a container is that it is to some extent isolated from the rest of the system, which can be a good thing, sometimes it just gets in the way however.

1 Like

Yes indeed.
Thank you.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.