Problem after updating Raspbian Stretch to Buster

@dceejay @wb666greene @krambriw I updated my RPI 3B with this tutorial :
Stretch to Buster Raspbian
The problem is, I can't access Node Red anymore.
It seems that the update did not work well. Secund problem i'm not Linux specialist ...

It looks like the update didn't work well because I can't see an IP address.

I remember having accepted, during the update, a program which used the DHCP function. it seems to me that NO was by default, and I put yes ...

Someone have an idea ?

Yes, it's no longer on the network.. If you do normally use DHCP then try sudo dhclient eth0 and then see if that gives you a connection... if so - then ping to check if internet is there and then redo sudo apt -y full-upgrade

If you usually use a static address then try sudo ifconfig eth0 w.x.y.z/24 (where w.x.y.z) is your normal address etc

respond : "cannot find device"eth0" :fearful:

is correct :


ah so it's back online... does the sudo apt -y full-upgrade now proceed ? if not what does cat etc/resolv.conf show for the nameserver ?

"no such file"

I may have a problem with the ethernet circuit driver? can I put it on a usb stick and reinstall it ?
the green led on the ethernet port is flashing so it is working ..

sorry - should have been cat /etc/resolv.conf - but it seems to be ok.
can you try to start Node-RED... node-red-stop && node-red-start

#Generated by resolvconf

yes its working !

and maybe this for the desktop sudo apt-get --reinstall install raspberrypi-ui-mods - but maybe just need to reboot first...
(meanwhile - you could also check the ffmpeg version which I think is where this all started...)

the reinstallation went well without error, but when I set the boot on DESKTOP GUI automatic login,

it starts on the Console :

PLUS : SSH is comeback that is great BUT the serial port, and VNC not working

what does /etc/init.d/lightdm start report ?

pi@pi:~ $ /etc/init.d/lightdm start
[....] Starting lightdm (via systemctl): lightdm.service==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentification requise pour démarrer « lightdm.service ».
Multiple identities can be used for authentication:
 1.  ,,, (pi)
 2.  root
Choose identity to authenticate as (1-2):

and ? pick pi if that is who you usually are...

sorry for delay response :
seems to be ok ....

unable to display desktop

vnc is well connected to the network, but the Desktop is not displayed. I also note a malfunction of the UART on the GPIO

the processor is overloaded and the swap memory is full
perhaps because of the UART issue ?

Stop NR and very low cpu charge

Thanks again @dceejay for your help that you already made me redo NR :slight_smile:

  1. It's good for the UART, I deleted the node and put it back in my flow: it's working now and I'm running at 5-8% CPU load

  2. the Desktop Buster still needs to work ...

Here is my last issue : i can not open the Buster Desktop.

When i type startx , it does't launch.
Here is the xorg log.txt (3.4 KB) about the problem :

[  8436.792]
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[  8436.792] Build Operating System: Linux 4.9.0-0.bpo.6-armmp armv7l Raspbian
[  8436.792] Current Operating System: Linux pi 5.4.77-v7+ #1371 SMP Tue Nov 17 13:32:02 GMT 2020 armv7l
[  8436.793] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.$
[  8436.793] Build Date: 27 August 2020  08:51:48AM
[  8436.793] xorg-server 2:1.20.4-1+deb10u1 (
[  8436.793] Current version of pixman: 0.36.0
[  8436.794]    Before reporting problems, check
        to make sure that you have the latest version.
[  8436.794] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  8436.794] (==) Log file: "/home/pi/.local/share/xorg/Xorg.0.log", Time: Sat Nov 21 15:31:24 2020
[  8436.795] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  8436.796] (==) No Layout section.  Using the first Screen section.
[  8436.796] (==) No screen section available. Using defaults.
[  8436.796] (**) |-->Screen "Default Screen Section" (0)
[  8436.796] (**) |   |-->Monitor "<default monitor>"
[  8436.798] (==) No device specified for screen "Default Screen Section".
        Using the first device section listed.
[  8436.798] (**) |   |-->Device "Allwinner A10/A13 FBDEV"
[  8436.798] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[  8436.798] (==) Automatically adding devices
[  8436.798] (==) Automatically enabling devices
[  8436.799] (==) Automatically adding GPU devices
[  8436.799] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  8436.799] (WW) The directory "/usr/share/fonts/X11/misc" does not exist.
[  8436.799]    Entry deleted from font path.
[  8436.799] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  8436.799]    Entry deleted from font path.
[  8436.799] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[  8436.799]    Entry deleted from font path.
[  8436.799] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[  8436.799]    Entry deleted from font path.
[  8436.799] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[  8436.799]    Entry deleted from font path.
[  8436.799] (==) FontPath set to:
[  8436.799] (==) ModulePath set to "/usr/lib/xorg/modules"
[  8436.799] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[  8436.799] (II) Loader magic: 0x1fcf80
[  8436.800] (II) Module ABI versions:
[  8436.800]    X.Org ANSI C Emulation: 0.4
[  8436.800]    X.Org Video Driver: 24.0
[  8436.800]    X.Org XInput driver : 24.1
[  8436.800]    X.Org Server Extension : 10.0
[  8436.813] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_33
[  8436.814] (II) no primary bus or device found
[  8436.814] (II) LoadModule: "glx"
[  8436.815] (II) Loading /usr/lib/xorg/modules/extensions/
[  8436.836] (II) Module glx: vendor="X.Org Foundation"
[  8436.836]    compiled for 1.20.4, module version = 1.0.0

There are defaut settings, from config file, informational, warning errors but how to solve then ?

PS : sudo apt-get --reinstall install raspberrypi-ui-mods did already do

If someone have an idea ?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.