Problem with sending multiple jsons to cloud, sends only the first one

Im sending Nordpool prices to cloud via Node-red. With the function I set the object and split after price so I have json for each hour with price. When I send it to the cloud, it shows only the first json data.

How can I send all the jsons to the cloud? I tried the delay node, but it only stops for the particular time before again sending all at once. how can I include a loop to the flow to solve this.


In your debug display, it looks like those messages are being send at lease 5 per second.
Are they using the same topic?
what options are the publisher using?
Are you sure it is the first msg that gets received or could it be the last?

You should install 'MQTT Explorer' on one of your devices so you can see what is being published. It is a great tool for looking at mqtt msgs.

using the same topic and yes its the first one
this is what the data on the cloud looks like

Im having Node red locally on my computer and using MQTT out node to publish to Fogwing cloud

Try adding an MQTT-in node connected to a debug node (set to display the complete msg object) and see if you receive multiple messages in from the broker.

Did you look at MQTT explorer?

the debug node with MQTT in node doesnt seem to work. the connection settings are the same, topic Qos and Retain should be ok as well.. still in cloud is only the first json.

MQTT explorer keeps connecting and disconnecting, the connection settings are the same as in Node red.

now it worked! got all the data to the cloud, when I changed the port from 8883 to 1883...

1 Like

is it possible to use somehow the trigger node to inject every hour so that at the particular hour only the right json would be send to the cloud ?

setting the inject for every hour..but how do I adjust the function

Why do you need to adjust the function if you are only getting a msg per hour?