Proxy Issue for exec node - curl

Hello guys
I am having a bit of an issue. That I have fixed most of; I am on the home stretch
I have currently spun a docker instance of the latest node-red version.
This is currently in a corp environment and it has to go through the proxy. I have whitelisted everything that I need whitelisting.
Within the main server I can confirm when I issue a curl similar to "curl --request GET --url https://URL --headerURL 'accept: application/json' --header 'x-apikeys:mykey'"
I am able to get the response back that I am expecting. This is because I setup the http proxy using this way.
I have setup ```
export https_proxy=https://your.proxy.server:port/

Keep in mind this export is not permanent when I logout it goes back to normal and I have to reissue it. (will resolve keeping the settings later)

the problem I have is the node red docker container. When I pipe in the the curl that I want into the exec node it times out due to proxy not being set.
Since I have portainer running I entered the console of the running container and issued the command from above. Since this command is not permanent it would appear it is applying it per user (logged in user)
I have tried "default user" and "root" both still end up with a timeout and curl not able to return any data.
I am not sure how to setup a proxy within the container itself. Is there a setting I am missing in the interface? or how do I setup a proxy within the node-red container?

Edit: I have tried this. It makes no difference
I have also tried this, which still didn't work and additionally broke my connection to the local docker database even when I set no proxy for a ip range



Any suggestions?

I'd suggest editing the title of your post to include "docker" as a non docker user as soon as I read docker in a post I'll leave it to the docker users.

Is there a particular reason you choose to use the exec node to run curl?

Have you looked at using the built-in HTTP Request node that allows you to configure a proxy within the node?