Raspbian Buster - Node red install script failure

with the latest raspbian buster image following an initial config and sudo apt-get update/upgrade I attempted to use the bash curl script from the docs page to install..
This failed at the Node/js install and according to the log due to an unknown command 'npm'
and npm was not installed ..
i used sudo apt-get install npm to install and retried the scrip, - same result!
I then attempted sudo apt install npm, followed by a sudo apt update and sudo apt upgrade
and then had success installing Node Red with the bash curl scrip which had failed before..

If this is a buggette on the side of Raspbian Buster which is getting updated pretty rapidly atm or an issue with the install script? I dont know but thought it worthy of mention in case it is.

Post the log from the installer please. It should be in /var/log/nodered-install.log
If you have run the installer multiple times then just post the result from the last run.

JFI I just installed Buster 2019-10-70 (Full) on a new Pi4 - didn't do update/upgrade - Node-RED installed fine

so the script worked for me