Rs485 serialport plug in

Hello Myself Iliyas,
I have been getting issue on installing rs485 serial port plugin please help as soon as possible

How to install in Dell gateway 5000

What have you tried and what issue have you encountered? There is no point us advising you unless we know what does not work.

I am installing rs485 serialport plugin but its not installing giving some errors

To ask basically the same questions again:
What plugin are you trying to install (exactly, not just descriptive words)?
How are you trying to install it - the command or sequence that you are using?
What errors? Copy/Paste here the errors you are seeing.

i am installing this
npm i node-red-node-serialport-rs485

i am getting this error
2019-08-16T10:56:56.900Z [err] node -v
2019-08-16T10:56:56.900Z [err] v12.8.1
2019-08-16T10:56:56.900Z [err] gyp ERR!
2019-08-16T10:56:56.900Z [err] node-gyp -v
2019-08-16T10:56:56.901Z [err] v5.0.3
2019-08-16T10:56:56.901Z [err] gyp
2019-08-16T10:56:56.901Z [err] ERR! not ok
2019-08-16T10:56:56.901Z [err]
2019-08-16T10:56:56.918Z [err] node-pre-gyp ERR! build error
2019-08-16T10:56:56.918Z [err] node-pre-gyp ERR! stack Error: Failed to execute '/usr/bin/node /usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/root/.node-red/node_modules/node-red-contrib-serialport-rs485/node_modules/serialport/build/Release/serialport.node --module_name=serialport --module_path=/root/.node-red/node_modules/node-red-contrib-serialport-rs485/node_modules/serialport/build/Release' (1)
2019-08-16T10:56:56.918Z [err] node-pre-gyp ERR! stack at ChildProcess. (/root/.node-red/node_modules/node-red-contrib-serialport-rs485/node_modules/serialport/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
2019-08-16T10:56:56.918Z [err] node-pre-gyp ERR! stack at ChildProcess.emit (events.js:203:13)
2019-08-16T10:56:56.918Z [err] node-pre-gyp ERR! stack at maybeClose (internal/child_process.js:1021:16)
2019-08-16T10:56:56.918Z [err] node-pre-gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:283:5)
2019-08-16T10:56:56.918Z [err] node-pre-gyp
2019-08-16T10:56:56.919Z [err]
2019-08-16T10:56:56.919Z [err] ERR!
2019-08-16T10:56:56.919Z [err]
2019-08-16T10:56:56.920Z [err] System
2019-08-16T10:56:56.920Z [err] Linux 4.4.0-103-generic
2019-08-16T10:56:56.921Z [err] node-pre-gyp
2019-08-16T10:56:56.921Z [err]
2019-08-16T10:56:56.921Z [err] ERR!
2019-08-16T10:56:56.921Z [err]
2019-08-16T10:56:56.922Z [err] command
2019-08-16T10:56:56.922Z [err] "/usr/bin/node" "/root/.node-red/node_modules/node-red-contrib-serialport-rs485/node_modules/serialport/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"
2019-08-16T10:56:56.923Z [err] node-pre-gyp
2019-08-16T10:56:56.923Z [err]
2019-08-16T10:56:56.923Z [err] ERR!
2019-08-16T10:56:56.924Z [err]
2019-08-16T10:56:56.924Z [err] cwd
2019-08-16T10:56:56.924Z [err] /root/.node-red/node_modules/node-red-contrib-serialport-rs485/node_modules/serialport
2019-08-16T10:56:56.925Z [err] node-pre-gyp
2019-08-16T10:56:56.925Z [err]
2019-08-16T10:56:56.925Z [err] ERR!
2019-08-16T10:56:56.925Z [err]
2019-08-16T10:56:56.926Z [err] node -v v12.8.1
2019-08-16T10:56:56.926Z [err] node-pre-gyp ERR! node-pre-gyp -v v0.6.32
2019-08-16T10:56:56.927Z [err] node-pre-gyp
2019-08-16T10:56:56.927Z [err]
2019-08-16T10:56:56.927Z [err] ERR!
2019-08-16T10:56:56.928Z [err]
2019-08-16T10:56:56.930Z [err] not ok
2019-08-16T10:56:56.930Z [out] Failed to execute '/usr/bin/node /usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/root/.node-red/node_modules/node-red-contrib-serialport-rs485/node_modules/serialport/build/Release/serialport.node --module_name=serialport --module_path=/root/.node-red/node_modules/node-red-contrib-serialport-rs485/node_modules/serialport/build/Release' (1)
2019-08-16T10:56:57.083Z [out] recipe for target 'Release/' failed
2019-08-16T10:56:57.083Z [out] make: Leaving directory '/root/.node-red/node_modules/node-red-contrib-serialport-rs485/node_modules/serialport/build'
2019-08-16T10:56:57.083Z [err] make: *** [Release/] Error 1
2019-08-16T10:56:57.088Z [err] gyp
2019-08-16T10:56:57.091Z [err]
2019-08-16T10:56:57.091Z [err] ERR!
2019-08-16T10:56:57.091Z [err] build error
2019-08-16T10:56:57.093Z [err] gyp
2019-08-16T10:56:57.093Z [err] ERR! stack
2019-08-16T10:56:57.093Z [err] Error: make failed with exit code: 2
2019-08-16T10:56:57.093Z [err] gyp
2019-08-16T10:56:57.093Z [err] ERR!
2019-08-16T10:56:57.094Z [err] stack at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:196:23)
2019-08-16T10:56:57.094Z [err] gyp
2019-08-16T10:56:57.094Z [err]
2019-08-16T10:56:57.094Z [err] ERR!
2019-08-16T10:56:57.094Z [err] stack at ChildProcess.emit (events.js:203:13)
2019-08-16T10:56:57.094Z [err] gyp ERR!
2019-08-16T10:56:57.094Z [err] stack
2019-08-16T10:56:57.094Z [err] at Process.ChildProcess._handle.onexit (internal/child_process.js:272:12)
2019-08-16T10:56:57.095Z [err] gyp
2019-08-16T10:56:57.095Z [err] ERR!

What do you see after that?

In general we don't fully support node12 yet - Can you revert to node 10 LTS ?

I am installing it in Dell gateway 5000

But its not installing to remove the previous version and download 10 LTS version?

That would depend on how you installed nodejs.

I have tried in 10 LTS also but too it not installing

Can you please tell how to install it properly?

You need to know how you installed nodejs v12

If you know how you did that try the same method for v10

I have tried the same method it has installed successfully but too I am getting the same erro

You say you are trying to install node-red-node-serialport-rs485, but the error seems to be about node-red-contrib-serialport-rs485

The contrib node will not install for me either, it has not been updated for two years, possibly it is not compatible with node 10.x

[Edit] I see where the confusion has arisen. The npm page talks about node-red-node-serialport-rs485 but is actually about node-red-contrib-serialport-rs485. Unfortunately it does not seem to have a link to a gitub repository so I can't see how to submit an issue. The only solution I can see is to use a different node, if there is one.

ok thanks bro

Hello. I had probably the same problem with this node. I have Weidmuller UC20-WL2000-IoT Controller with web Node-RED? ver.1.0.3. I'm trying to add a rs485 node to my flow, when I try to install "node-red-contrib-serialport-rs485", I get an error:

2023-04-25T13:47:43.975Z Install : node-red-contrib-serialport-rs485 0.0.6

2020-01-28T12:09:20.753Z npm install --no-audit --no-update-notifier --save --save-prefix="~" --production node-red-contrib-serialport-rs485@0.0.6
2020-01-28T12:09:33.654Z [err] npm ERR! code EAI_AGAIN
2020-01-28T12:09:33.654Z [err] npm ERR! errno EAI_AGAIN
2020-01-28T12:09:33.664Z [err] npm
2020-01-28T12:09:33.674Z [err]  ERR! request to ``````failed, reason: getaddrinfo EAI_AGAIN
2020-01-28T12:09:33.804Z [err] 
2020-01-28T12:09:33.804Z [err] npm ERR! A complete log of this run can be found in:
2020-01-28T12:09:33.804Z [err] npm ERR!     /tmp/node-red/.npm/_logs/2020-01-28T12_09_33_679Z-debug.log
2020-01-28T12:09:33.833Z rc=1

May be you've been already find decision?

Regards, Alex.

I am closing this old thread as you have also started a new thread for it.