Send picture telegram - NO USB CAMERA, the nightmare continues

Hi all!

I'm working on this project again (Send picture telegram - NO USB CAMERA - #38 by Marty1982), but i'm stuck on the same place over again. The thing is that i can upload a picture via telegram, the node can recognize it but the TensorFlow cannot process it and make the correct output.

Anyone did try this idea?.

Yes, I remember. You where running your stuff in docker and got error messages related to jimp? Is this still the case?

What happens if you inject an image locally (instead of sending it via Telegram). Does the analyze work then? Is it still problems when you receieve that image via Telegram?

What is your status and flow right now?

In my case I have no problems as you have already seen, it works fine but my setup is different, no docker, I run it directly in a RPi3 B+

Hi! I'm in the same case...but now is not related to JIMP because i want to inject an image directly from Telegram and the JIMP issue is when you want to inject an image from an USB camera.

If i inject an image directly it works as spected and anaylize it correctly.

This is my workflow now:

[{"id":"e19d4f1c.b6a05","type":"change","z":"28cdadc8.e454e2","name":"","rules":[{"t":"move","p":"payload.weblink","pt":"msg","to":"url","tot":"msg"}],"action":"","property":"","from":"","to":"","reg":false,"x":280,"y":240,"wires":[["fe6a4634.b60788"]]},{"id":"516b7b37.4c9314","type":"debug","z":"28cdadc8.e454e2","name":"","active":false,"tosidebar":true,"console":false,"tostatus":false,"complete":"payload","targetType":"msg","statusVal":"","statusType":"auto","x":466,"y":174,"wires":[]},{"id":"5153eb3c.f77204","type":"image","z":"28cdadc8.e454e2","name":"","width":160,"data":"url","dataType":"msg","thumbnail":false,"active":true,"pass":false,"outputs":0,"x":680,"y":320,"wires":[]},{"id":"cda6f0d.c82fe1","type":"image","z":"28cdadc8.e454e2","name":"","width":160,"data":"url","dataType":"msg","thumbnail":false,"active":true,"pass":false,"outputs":0,"x":920,"y":160,"wires":[]},{"id":"fe6a4634.b60788","type":"http request","z":"28cdadc8.e454e2","name":"","method":"use","ret":"bin","paytoqs":"ignore","url":"","tls":"","persist":false,"proxy":"","authType":"","x":510,"y":240,"wires":[["5153eb3c.f77204","99e49229.2012b"]]},{"id":"99e49229.2012b","type":"tensorflowCoco","z":"28cdadc8.e454e2","name":"","modelUrl":"http://localhost:1880/coco/model.json","scoreThreshold":0.5,"passthru":"false","lineColour":"magenta","x":740,"y":140,"wires":[["cda6f0d.c82fe1"]]}]

You have to add the Telegram node at the beggining like this.

So, if i send an image, the workflow works ok until the first image preview, also, i can see the sent image.

The problem is that TensorFlow cannot process the image and tell me what is the object.


I see you have the TF node set for a local model - have you tried clearing that to use the internet model?

Try to set the method to GET in the http request node


Now i got it!

The problem for me was the TF node. I've replaced it to another node and it works.

Thanks !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.