Shelly 1PM Gen2 has no "mqtt_update_periode"?


Can I set the update interval for status message in shelly 1pm Gen2 like in Gen1?

Additional infos:
I've managed to implement my shelly 1pm into node-red.
With the xx/status/switch:0 I get nearly every second a update:


I saw in the Gen 1 Docs, that there is a setting -> mqtt_update_periode. Because in my flow I get every second an update - this is way too much!
Is there something similar for the gen2

Thanks for your help.

You can use scripts on shelly gen 2 devices, not tried as do not have any gen 2 yet.
Generate periodic messages

1 Like

Thanks for your reply.

But as far as I can see, is this just a periodic message (yes I could make HTTP-Requests...). All these things I can fullfil within in nodered.


Yes a periodic message of what ever info you wish to send, you can create any script you wish.

Maybe I am not understanding your request

If you require notifications when things have changed Notifications | Shelly Technical Documentation

I'm getting the status on the standard topic ../status/switch:0


Everything works fine BUT! I got the message every SECOND! I'm sure this could be changed - as in GEN1 with "mqtt_update_periode" but I'm not able to find in the docs....

As said I do not have a device, I cannot find any info in gen2 docs that show the ../status/switch:0 topic.
As far as i have read Shelly GEN2 try to limit network chatter.
So it publishing status every second seems strange to me.
I thought GEN2 MQTT uses <shelly-id>/rpc topics and commands and data where json, except notifications which are <shelly-id>/events/rpc, and for periodic status updates you would use scripts.

1 Like

Thanks again for your reply - really appreciate it!

In the docu under ShellyPlus1PM you can find the topic "switch:0" - and I catched this topic with MQTT Explorer.

I also read that GEN2 try to limit network chatter - and sending every second those messages are exactly the opposite :smiley: And the problem - also when I'm implementig scripts... shelly will sent this message nevertheless

okay, than I will try the scripts and create my own "status" infos

edit: also on the topic "myshelly/events/#" I get every second a message...
Over the dayit is ~ 17MB: JSON has ~ 200B * 60 * 60 *24 ~ 17 mb on traffic


I got recently some gen2 Shelly but not the 1pm
The documentation is optimized in the way they reduce number of page of website but it does not help to see which setting are really available on each device type.
The network chatter reduction seems to apply more on the battery powered device, not sure if the 240V AC powered device have this option.
I would advice to check in the rpc status, which wake_up reason is given.
There are wake up period parameter but I am not sure, as said before, that they apply in case of AC supply.

Pierre RUWET

1 Like

Interessting - according to the docs the last two items of Sys.GetStatus should have "wakeup_reason" and "wakeup_period"
(System | Shelly Technical Documentation)

I haven't both of them

Right above that section is says
Information about boot type and cause (only for battery-operated devices)

1 Like

My Second Shelly 1PM hasn't this behaviour - also a factory reset hasn't changed the mass flood on mqtt message... Whatever

So I switched to the second one and there everything looks good:

With ../rpc Topic and method "Switch.GetStatus" I get all my desired Infos.

Thank you all for your inputs!

found it - uncheck both notification and everything is good!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.