Tab env() not being seen when I try to read them

I seem to be going in ever decreasing circles with this problem.

So I have set two variables.
FOO and blah.

Ignore the debug stuff at this stage. That was from other tests.

So Those are defined. I DEPLOY the flow and press the inject node to read the env.FOO value.

All I get is ""
I then try with the env.blah and get the same.

Now this is really doing my head in because I had all this on ANOTHER TAB: and it worked.
I moved it because that tab was for something else and I didn't want this test on it.
So I cut/pasted it to a new tab and set the env variables - as shown.

Why would it work when on one tab, then when I move to a new tab (and set the env variables on it) it doesn't work.

For the sake of further burning myself, I added a third env variable.

Then (as you can already see) I tried to access it. It works.
I won't paste the screen shot of the change node.

I have (as you can also see) changed the FOO and blah to TEXT. Still doesn't work.

As a sheer attempt to try anything I went up and selected restart all flows.

Now it works.

Go figure.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.