Uibuilder & Node RED 2.0.2

Hi out there,
while uibuilder 3.1.3 is running under Node RED 1.2.6 (node.js 12.20.0) like a charm the output usinge recent Versions (uibuilder 4.1.1, Node RED 2.0.5, node.js 12.20.0) is quite "corrupt".


The - not expected - result is

Any idea?
Thank you so much

I seem to recall reading in many topics now that Node-Red 2.0.x should be using node.js 14+ Perhaps that is contributing to your issue?

Well it looks like you've ended up with the new "blank template" which is, as the name says ... blank :grinning:

v4 made some very significant changes to template handling so that we could move uibuilder forward more rapidly.

To have the same template as previous versions, change the template:


Just note the warnings that tell you all of your code is going to be overwritten so make a backup if you've changed anything. BTW, you still get another chance to back out even if you press the load button.

V4+ now defaults to the blank template.

As a side note, if you ever think that uibuilder's front-end is doing something weird, add uibuilder.debug(true) immediately after your uibuilder.start and reload the page, Now, open the browser dev tools and have a look at the console. You will be getting lots of output showing you exactly what is going on.

No, v12 is still OK while it is still an LTS version. I had to move uibuilder to v12 as a minimum in v4 because of upstream dependencies. In the world of node.js and JavaScript, I'm afraid things move super fast. Actually, I can't wait until v14 becomes the accepted minimum as that puts in place some nice enhancements for classes.

1 Like

I guess it was recalling the references of "12 soon to be 14+" that I was recalling. I run 14

That and I shouldn't have bothered posting as I don't run uibuilder anyhow :stuck_out_tongue:

Hi Julian,
thank yu so much for the quick response. Everything is working fine now. :+1:
Have a nice time.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.