Unzip Error Cannot read property 'getNode' of undefined"


I use node-red-contrib-zip node to unzip the zip file.
With version 1.0.0, unzip is OK, but the latest version is currently 1.1.0. then unzip error as attached picture.
Anyone have the same error as me? :frowning:

[{"id":"6f540e71.39d5a","type":"inject","z":"8289d019.722ce","name":"","topic":"","payload":"","payloadType":"str","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":170,"y":2500,"wires":[["286c8a8c.05da26"]]},{"id":"286c8a8c.05da26","type":"change","z":"8289d019.722ce","name":"","rules":[{"t":"set","p":"filename","pt":"msg","to":"D:\\Work\\DataTest.zip","tot":"str"}],"action":"","property":"","from":"","to":"","reg":false,"x":330,"y":2500,"wires":[["5613d8b8.b08818"]]},{"id":"227c1acb.66ff26","type":"zip","z":"8289d019.722ce","name":"","mode":"decompress","filename":"","compressionlevel":6,"outasstring":false,"x":630,"y":2500,"wires":[["e0483459.b852d8"]]},{"id":"5613d8b8.b08818","type":"file in","z":"8289d019.722ce","name":"","filename":"","format":"","chunk":false,"sendError":false,"encoding":"none","x":490,"y":2500,"wires":[["227c1acb.66ff26"]]},{"id":"e0483459.b852d8","type":"debug","z":"8289d019.722ce","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"true","targetType":"full","x":770,"y":2500,"wires":[]}]

I would suggest you report this to the author on the GitHub page Issues · gfcittolin/node-red-contrib-zip · GitHub

1 Like

Yes, I reported this to the author.

You can install the older version from the command line.

  1. open a terminal window
  2. change directories to the .node-red folder
  3. enter
    npm install node-red-contrib-zip@1.0.0
1 Like

Because version 1.0.0 when unzip exception occurs it cannot be caught by catch node,
so I want to use version 1.1.0

What does the file contain?
What version of NR are you running?

Inside the zip file contains text files.
I'm using NR v0.20.7

Why are you using such an old version of node-red? It is currently at v1.3.5

@zenofmud I'm still running 0.9 on one box... if it works don't fix it. Updating it won't fix this node.

1 Like

Can you provide a file that causes the issue. I'm not able to reproduce your issue.

I tried with NR v1.1.3, unzip file is OK
Maybe the error is due to the old version of NR....

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.