Updated to Node 16 and now have issues installing/updating nodes ("boom@0.3.8")

I want to make use of node-red-contrib-discord-advanced and therefore upgraded to Node 16 from 14 (minimum requirement). Now, when trying to install the module or updating another module I get the following error:

2022-10-21T12:50:37.392Z [err]  Not compatible with your version of node/npm: boom@0.3.8
2022-10-21T12:50:37.392Z [err] npm
2022-10-21T12:50:37.393Z [err] ERR!
2022-10-21T12:50:37.394Z [err] notsup
2022-10-21T12:50:37.394Z [err]  Required: {"node":"0.8.x"}
2022-10-21T12:50:37.394Z [err] npm
2022-10-21T12:50:37.395Z [err] ERR!
2022-10-21T12:50:37.396Z [err] notsup
2022-10-21T12:50:37.397Z [err]  Actual:   {"npm":"8.19.2","node":"v16.18.0"}

Can I fix this or should I roll back/downgrade?

Hi @yesdred

According to its page on npm, the module boom is deprecated and has been replaced by @hapi/boom which is actively maintained.

In that situation, I'd certainly be looking to update the module. Node 0.8 has not been supported for a very long time and really should not be used.

How you migrate from boom to @hapi/boom will depend very much on how/why you have that module installed. If it is something you are using directly, then you'll need to migrate your code to use the new module.

If it is a module installed because it is a dependency of something else, you'll need to look at what updates are available.

If you aren't sure, then run npm list boom in ~/.node-red/ to see where it is in the dependency tree.

1 Like

Thank you Nick for the quick response. I found the culprit in node-red-contrib-dns@0.0.4, figured out I don't really need it and uninstalled it. I can now use my Discord bot to receive home automation commands.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.