USB HID RELAY node - question/s

I just saw this in the "library":


I can't resolve how to ask the person, so here goes:

(From the page)
Models supported:

Models with USB-Relay-1, USB-Relay-2 or USB-Relay-4 printed on the PCB


Looking on the interweb, I find this (as example)
USB HID relay boards

But I am not sure if they are compatible.

I've opened one of the boards and read the specs, but can't find if they are HW-348 (etc) drivers (what ever).

Just asking.

1 Like

I tried with github, but missed that part.


I also need help.

I used this relay board;

It does not have the relay numbers on the circuit board, so I assume it is incorrect? Can someone point me to a correct board?

Also, followed all of the steps on the github link provided by ukmoose.

I noted on your gethub page there was additional instruction under "Linux Dependencies". I have not completed these instructions. Are they necessary? I did not see these on the Node-Red product description page.

I did navigate to the "udev" folder and tried to make a new folder named "rules.d/50-hidrelay.rules', but my copy of Raspian says I do not have permission.

So, can someone kindly help me to set up your Node considering I have no programming knowledge?


Of course you have to follow the description/instruction to succeed

Use sudo

Then you might get into problems but Node-RED should be possible to configure anyway, almost
What you definitely need to know is a bit how Linux works, using the terminal, the linux commands for creating the rules, how to edit a text/config file, how to set permissions, what sudo & nano is, etc

Thanks Walter

I looked up sudo and nano as you suggested. I learned enough to add the rule file as instructed.

Appears to be working now.


1 Like

Hi There
Whe i try to install this node i get this:

2020-04-03T09:49:56.248Z installieren : node-red-contrib-usb-hid-relay 0.2.5

2020-04-03T09:49:58.865Z npm install --no-audit --no-update-notifier --save --save-prefix="~" --production node-red-contrib-usb-hid-relay@0.2.5
2020-04-03T09:50:56.182Z [err] npm WARN registry Unexpected warning for (#cant post link):// Miscellaneous Warning ENODATA: Cache input stream was empty
2020-04-03T09:50:56.198Z [err] npm WARN registry Using stale data from due to a request error during revalidation.
2020-04-03T09:50:57.018Z [err] npm ERR! code EINTEGRITY
2020-04-03T09:50:57.018Z [err] npm ERR! errno EINTEGRITY
2020-04-03T09:50:57.048Z [err] npm
2020-04-03T09:50:57.058Z [err] ERR! Invalid response body while trying to fetch (#cant post link)/ Integrity verification failed for sha512-/Kthe/FKa/6STqnuw7C7lZbJxatsA+UuG1ZUZasmm5cHrGUq7/O9VZs5j8slZGga3z35JBuV8+z6vQ0MjTvW6A== (/home/pi/.npm/_cacache/content-v2/sha512/fc/ab/617bf14a6bfe924ea9eec3b0bb9596c9c5ab6c03e52e1b565465ab269b9707ac652aeff3bd559b398fcb2564681adf3df9241b95f3ecfabd0d0c8d3bd6e8)
2020-04-03T09:50:57.628Z [err]
2020-04-03T09:50:57.628Z [err] npm ERR! A complete log of this run can be found in:
2020-04-03T09:50:57.628Z [err] npm ERR! (#cant post link)
2020-04-03T09:50:57.710Z rc=1

NodeRed is running on a Pi1, allready updated and edit what in the descrition is written down

Did i miss something?

Thanks for Help

Greetings from Hamburg / Germany

That looks like a network issue I think. Try again to see if it has recovered. If not then can you access in a browser?