Why my lamp is going when bigtimer is set

Hello guys, i have a ikea motion sensor and use it the halway, now i want that the lamp only goes on when there is motion in the morning and night

what do i wrong in my flow

[{"id":"7bae246d.839dfc","type":"tab","label":"Flow 2","disabled":false,"info":""},{"id":"4b7c590a.f56cf8","type":"trigger","z":"7bae246d.839dfc","name":"","op1":"ON","op2":"OFF","op1type":"str","op2type":"str","duration":"90","extend":true,"units":"s","reset":"","bytopic":"all","topic":"topic","outputs":1,"x":870,"y":40,"wires":[["92cae6d8.0fa0e8"]]},{"id":"92cae6d8.0fa0e8","type":"Tasmota Switch","z":"7bae246d.839dfc","broker":"80cd643f.d8bb58","device":"hal","name":"Lamp Hal","outputs":1,"uidisabler":false,"fullTopic":"%topic%/%prefix%/","cmndPrefix":"","statPrefix":"","telePrefix":"","x":1040,"y":40,"wires":[[]]},{"id":"e780029b.2cd52","type":"mqtt in","z":"7bae246d.839dfc","name":"Motion Hal","topic":"zigbee2mqtt/0x680ae2fffe36ddc8","qos":"0","datatype":"json","broker":"80cd643f.d8bb58","x":60,"y":40,"wires":[["6ac7a8bd.da7478"]]},{"id":"6ac7a8bd.da7478","type":"change","z":"7bae246d.839dfc","name":"","rules":[{"t":"move","p":"payload.occupancy","pt":"msg","to":"payload","tot":"msg"}],"action":"","property":"","from":"","to":"","reg":false,"x":190,"y":120,"wires":[["e9d0cac9.447bd8"]]},{"id":"e9d0cac9.447bd8","type":"switch","z":"7bae246d.839dfc","name":"","property":"payload","propertyType":"msg","rules":[{"t":"true"}],"checkall":"true","repair":false,"outputs":1,"x":370,"y":40,"wires":[["5f9f33b9.b081bc"]]},{"id":"5f9f33b9.b081bc","type":"change","z":"7bae246d.839dfc","name":"","rules":[{"t":"set","p":"payload","pt":"msg","to":"ON","tot":"str"}],"action":"","property":"","from":"","to":"","reg":false,"x":520,"y":40,"wires":[["59050aab.8bfbb4","1deefb9d.fcbae4"]]},{"id":"1deefb9d.fcbae4","type":"debug","z":"7bae246d.839dfc","name":"","active":false,"tosidebar":true,"console":false,"tostatus":false,"complete":"false","statusVal":"","statusType":"auto","x":730,"y":120,"wires":[]},{"id":"59050aab.8bfbb4","type":"bigtimer","z":"7bae246d.839dfc","outtopic":"","outpayload1":"ON","outpayload2":"OFF","name":"Big Timer","comment":"","lat":"52.2661° N","lon":"6.1552° E","starttime":"1080","endtime":"480","starttime2":0,"endtime2":0,"startoff":0,"endoff":0,"startoff2":0,"endoff2":0,"offs":0,"outtext1":"","outtext2":"","timeout":"1440","sun":true,"mon":true,"tue":true,"wed":true,"thu":true,"fri":true,"sat":true,"jan":true,"feb":true,"mar":true,"apr":true,"may":true,"jun":true,"jul":true,"aug":true,"sep":true,"oct":true,"nov":true,"dec":true,"day1":0,"month1":0,"day2":0,"month2":0,"day3":0,"month3":0,"day4":0,"month4":0,"day5":0,"month5":0,"day6":0,"month6":0,"day7":0,"month7":0,"day8":0,"month8":0,"day9":0,"month9":0,"day10":0,"month10":0,"day11":0,"month11":0,"day12":0,"month12":0,"d1":0,"w1":0,"d2":0,"w2":0,"d3":0,"w3":0,"d4":0,"w4":0,"d5":0,"w5":0,"d6":0,"w6":0,"xday1":0,"xmonth1":0,"xday2":0,"xmonth2":0,"xday3":0,"xmonth3":0,"xday4":0,"xmonth4":0,"xday5":0,"xmonth5":0,"xday6":0,"xmonth6":0,"xd1":0,"xw1":0,"xd2":0,"xw2":0,"xd3":0,"xw3":0,"xd4":0,"xw4":0,"xd5":0,"xw5":0,"xd6":0,"xw6":0,"suspend":false,"random":false,"repeat":false,"atstart":false,"odd":false,"even":false,"x":700,"y":40,"wires":[["4b7c590a.f56cf8"],[],[]]},{"id":"80cd643f.d8bb58","type":"mqtt-broker","z":"","name":"","broker":"192.168.2.23","port":"1883","clientid":"","usetls":false,"compatmode":true,"keepalive":"60","cleansession":true,"birthTopic":"","birthQos":"0","birthRetain":"false","birthPayload":"","closeTopic":"","closeQos":"0","closePayload":"","willTopic":"","willQos":"0","willPayload":""}]

As far as I know, the bigtimmer node outputs a msg basd on it's settings. If you only want the lamp to go on in the morning and night, I would add a change node right after the mqtt-in node and st msg.timestamp to 'timestamp. Then compare it to the time range you want to have the lamp active.

don't know how to do that

add a change node to the output of the mqtt-in node. In the 'change' node options, set it like this:

Screen Shot 2020-11-04 at 7.07.24 AM

Then you can use a switch node to test the time against the times you want it to work.

solved, lamp only goes on when it is between sunrise and sunset, and when it get motion.
Lamp goes off after 90 seconds.

[{"id":"38033fc.f8dddc","type":"bigtimer","z":"7bae246d.839dfc","outtopic":"","outpayload1":"true","outpayload2":"false","name":"Big Timer","comment":"","lat":"52.266075","lon":"6.155217","starttime":"5004","endtime":"5003","starttime2":0,"endtime2":0,"startoff":0,"endoff":0,"startoff2":0,"endoff2":0,"offs":"0","outtext1":"","outtext2":"","timeout":1440,"sun":true,"mon":true,"tue":true,"wed":true,"thu":true,"fri":true,"sat":true,"jan":true,"feb":true,"mar":true,"apr":true,"may":true,"jun":true,"jul":true,"aug":true,"sep":true,"oct":true,"nov":true,"dec":true,"day1":0,"month1":0,"day2":0,"month2":0,"day3":0,"month3":0,"day4":0,"month4":0,"day5":0,"month5":0,"day6":0,"month6":0,"day7":0,"month7":0,"day8":0,"month8":0,"day9":0,"month9":0,"day10":0,"month10":0,"day11":0,"month11":0,"day12":0,"month12":0,"d1":0,"w1":0,"d2":0,"w2":0,"d3":0,"w3":0,"d4":0,"w4":0,"d5":0,"w5":0,"d6":0,"w6":0,"xday1":0,"xmonth1":0,"xday2":0,"xmonth2":0,"xday3":0,"xmonth3":0,"xday4":0,"xmonth4":0,"xday5":0,"xmonth5":0,"xday6":0,"xmonth6":0,"xd1":0,"xw1":0,"xd2":0,"xw2":0,"xd3":0,"xw3":0,"xd4":0,"xw4":0,"xd5":0,"xw5":0,"xd6":0,"xw6":0,"suspend":false,"random":false,"repeat":false,"atstart":false,"odd":false,"even":false,"x":680,"y":40,"wires":[["6e93a46e.bebb8c","92cae6d8.0fa0e8"],[],[]]}]