2024 Install Attempt on Pi-Zero-W - some things have changed

First issue that I ran into was that Node js has been deprecated on the ARM6 Pi-Zero architecture.

I found this post about installing the 'experimental' versions.

Now when I run the node-red installer it seems to run but I do not end up with a node-red or a node-red-pi executable in my /usr/bin directory.

ls /usr/bin/node*
/usr/bin/node          /usr/bin/node-red-reload   /usr/bin/node-red-start
/usr/bin/node-red-log  /usr/bin/node-red-restart  /usr/bin/node-red-stop

There were no ominous warnings in the log file and the only visual from the installer was the final two lines of output

Running Node-RED install for user me at /home/me on raspbian

This can take 20-30 minutes on the slower Pi versions - please wait.

  Stop Node-RED                       ✔
  Remove old version of Node-RED      ✔
  Node option not specified           :   --node18 or --node20
  Leave existing Node.js              :   v20.11.1   Npm 10.2.4
  Clean npm cache                     -
  Install Node-RED core               ✔   4.0.2
  Move global nodes to local          -
  Leave existing nodes                -
  Install extra Pi nodes              ✔
  Add shortcut commands               ✔
  Update systemd script               ✔

Any errors will be logged to   /var/log/nodered-install.log
All done.
You can now start Node-RED with the command  node-red-start
  or using the icon under   Menu / Programming / Node-RED
Then point your browser to localhost:1880 or http://{your_pi_ip-address}:1880

Started :  Mon  8 Jul 09:36:43 EDT 2024
Finished:  Mon  8 Jul 09:48:40 EDT 2024

 ### WARNING ###

 Even if your Node-RED doesn't have anything valuable, (automated) attacks will
 happen and could provide a foothold in your local network

 Follow the guide at https://nodered.org/docs/user-guide/runtime/securing-node-red
 to setup security.

  - Remove the /etc/sudoers.d/010_pi-nopasswd file to require entering your password
    when performing any sudo/root commands:

      sudo rm -f /etc/sudoers.d/010_pi-nopasswd

  - You can customise the initial settings by running:

      node-red admin init

  - After running Node-RED for the first time, change the ownership of the settings
    file to 'root' to prevent unauthorised changes:

      sudo chown root:root ~/.node-red/settings.js


sudo: /usr/bin/node-red: command not found
chown: cannot access '/home/me/.node-red/settings.js': No such file or directory
 ls -la .node-red
total 32
drwxr-xr-x  3 me me 4096 Jul  8 09:43 .
drwx------  6 me me 4096 Jul  8 09:42 ..
drwxr-xr-x 16 me me 4096 Jul  8 09:43 node_modules
-rw-r--r--  1 me me 448 Jul  8 09:43 package.json
-rw-r--r--  1 me me 13066 Jul  8 09:43 package-lock.json

See this thread for recent discussion about the problem

working on a workaround as we speak...

1 Like