Admin Authentication stops Node-RED

I have a Node-RED system that has been running as a service on Windows 10 for a year or so now and have had admin authentication enabled this whole time. Yesterday, I was unable to log in. I used "node-red-admin hash-pw" to create a new hash for my password but was still not able to log in. I decided to upgrade to v0.20.7 (I was on v0.20.5 and still running node.js v8.9.4) just for the sake of doing it but still no go. I have created a new hash multiple times, changed the password, and even created a new user in the settings.js file but I still have the same issue. If I comment out the "adminAuth" section in the settings.js file then I can access the web interface without issues (except now it isn't secured).

I decided to stop the Node-RED service and just run it from the command line to see if any registered there. What is interesting is that as soon as I click the Login button the console stops (basically acts like I did a Ctrl+C and just puts me back to a command prompt). Nothing is logged in the console when I do this. I tried running under Verbose but nothing showed there when I clicked Login either. Running in Safe Mode produces the same issue. Lastly, I changed the logging in the settings.js file to Trace and set both metrics and audit to True and still nothing gets logged when I press the login button. It is essentially crashing Node-RED with seemingly no trail as to why.

The only errors that do show in the console are related to my Twitter credentials being wrong and it not being able to listen on port 8001. Both of those have been in there for a while and I know what those issues are.

I'm using Nssm to run it as a service. In the Windows event log, I see this message after trying to log in:

Program c:\Users\Demo\AppData\Roaming\npm\node-red.cmd for service Node-RED exited with return code 3228369023.

I did some Googling around and found a lot of mentions of that return code related to Node but seems to all be related to people having issues with writing code and getting that error.

I'm not sure where else to look and I'm out of ideas.


Have you found any solution? I'm having the same issue with all new Node 12 and node-red 1.0.3.

Alex Gouvea Vasconcelos

I never found a solution. However, I recently upgraded to v1.0.3 and I haven't tried since then. It is my work system so I won't be able to try until Monday to see if upgrading fixed it. Beings you are seeing it on v1.0.3, I'm not holding my breath that it is fixed.

Maybe someone else has some ideas. It is a weird issue. If I can find the time, I'll try digging around to see if I can find any other log files that might point to something.

I just tried on my system and everything is working now. I hadn't tried in a few months and, during that time, in addition to upgrading to 1.0.3, I have also uninstalled and updated various nodes. So, I'm not sure what actually fixed that issue.