After pressing the deploy button nothing happens on the client

After a pretty hard error from my system blocking the use of screenshotting (idk why dude), node-red would not start until I deleted nodejs and reinstalled, now it launches, but when I press deploy, it says it worked but nothing on the computer actually happened. help

3 May 16:55:28 - [info]

Welcome to Node-RED

3 May 16:55:28 - [info] Node-RED version: v2.2.2
3 May 16:55:28 - [info] Node.js  version: v16.15.0
3 May 16:55:28 - [info] Windows_NT 10.0.19043 x64 LE
3 May 16:55:29 - [info] Loading palette nodes
3 May 16:55:30 - [info] Settings file  : C:\Users\jimdi\.node-red\settings.js
3 May 16:55:30 - [info] Context store  : 'default' [module=memory]
3 May 16:55:30 - [info] User directory : \Users\jimdi\.node-red
3 May 16:55:30 - [warn] Projects disabled : editorTheme.projects.enabled=false
3 May 16:55:30 - [info] Flows file     : \Users\jimdi\.node-red\flows.json
3 May 16:55:30 - [info] Creating new flow file
**3 May 16:55:30 - [info] Server now running at** an IP i think so im not just gonna show that
3 May 16:55:30 - [info] Starting flows
3 May 16:55:30 - [info] Started flows

Welcome to the forum!

Hi, have you created a flow at all before you press "Deploy"?

Let's assume for example it says server now running at

What do you get if you point your browser (on that pc) to

Unless your computer is directly accessible from the internet, there is little point in hiding it.

if it says 192.x.y.z or - they cannot be accessed across the internet.

Did you add nodes? What did you add? Did the node-red console say something like...

4 May 09:52:05 - [info] Stopping modified nodes
4 May 09:52:05 - [info] Stopped modified nodes
4 May 09:52:05 - [info] Starting modified nodes
4 May 09:52:05 - [info] Started modified nodes

where there any errors after those messages?

Those paths look a little weird - any windows users out there can confirm that is how we display them ? I would expect - C:\Users\jimdi.node-red\settings.js with a \ before the .node-red

Its a forum forumatting issue.

@Powersaj-Tech logs/code/flows/json etc should be surrounded by three backticks

like this

I will update your post.

1 Like

Well, i added inject, and then tried to move my mouse with a couple nodes i downloaded

I believe i created a flow, here's what I did before I pressed Deploy

then i got this

4 May 07:54:09 - [info] Started flows
4 May 07:54:58 - [info] Stopping flows
4 May 07:54:58 - [info] Stopped flows
4 May 07:54:58 - [info] Starting flows
4 May 07:54:58 - [info] Started flows

This is what happens every time btw, doesn't matter what I do

Also credentials file is encrypted and idk why that happens

Don't worry about that for now.

So it looks like everything is OK. When you press "Deploy" it just stores the changes
you made to your flow(s).

So, what about actually starting the code? Do i just keep pressing deploy?

Flows start automatically after you press "Deploy", the flow you posted above is waiting for you to press the button on the left of the inject mode. You can then try setting automatic inject intervalls. Watch the debug pane to see what is happening.

1 Like

I recommend watching this playlist: Node-RED Essentials. The videos are done by the developers of node-red. They're nice & short and to the point. You will understand a whole lot more in about 1 hour. A small investment for a lot of gain.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.