@arduino/node-red-contrib-arduino-iot-cloud 1.0.7 fails to install

Hello I've just tried to install the @arduino/node-red-contrib-arduino-iot-cloud 1.0.7 node but I received an error.

2023-01-07T13:42:07.308Z Install : @arduino/node-red-contrib-arduino-iot-cloud 1.0.7

2023-01-07T13:41:45.304Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict @arduino/node-red-contrib-arduino-iot-cloud@1.0.7
2023-01-07T13:41:48.068Z [err] npm
2023-01-07T13:41:48.070Z [err]  
2023-01-07T13:41:48.070Z [err] WARN config
2023-01-07T13:41:48.071Z [err]  production Use `--omit=dev` instead.
2023-01-07T13:41:57.527Z [err] npm
2023-01-07T13:41:57.528Z [err]  ERR!
2023-01-07T13:41:57.528Z [err]  code ENOENT
2023-01-07T13:41:57.530Z [err] npm
2023-01-07T13:41:57.530Z [err]  ERR! syscall
2023-01-07T13:41:57.531Z [err]  spawn git
2023-01-07T13:41:57.532Z [err] npm 
2023-01-07T13:41:57.532Z [err] ERR! path git
2023-01-07T13:41:57.539Z [err] npm ERR! errno -2
2023-01-07T13:41:57.546Z [err] npm ERR! enoent An unknown git error occurred
2023-01-07T13:41:57.548Z [err] npm ERR! enoent This is related to npm not being able to find a file.
2023-01-07T13:41:57.548Z [err] npm ERR! enoent 
2023-01-07T13:41:57.576Z [err] 
2023-01-07T13:41:57.576Z [err] npm ERR! A complete log of this run can be found in:
2023-01-07T13:41:57.576Z [err] npm ERR!     /mnt/dietpi_userdata/node-red/.npm/_logs/2023-01-07T13_41_47_957Z-debug-0.log
2023-01-07T13:41:57.624Z rc=254

@arduino/node-red-contrib-arduino-iot-cloud 1.0.7

Any ideas?


I think that means that you have to have git installed. It should say that in the readme, but I see that it does not.

Great thanks, that worked :+1:

It should say that in the readme. It would be worth submitting an issue on the node's github page (which is linked from the node's page on the node red flows site) pointing out the fact that this is missing from the readme.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.