Authentication errors with Projects/HTTPS GitHub

Hi,

I'm using Node-Red 1.1.1 stand alone. I'm wanting to use projects and have actually managed to create it and push to HTTPS: GitHub once. A week later I wanted to push some changes and I get Authentication failed. I recreated the access token on GitHUB but now can't find any way to change the token in my Node-Red project.

2020-07-31_09-42-51

Doug

Node-RED only stores Auth details in memory, so if you restart Node-RED it will prompt you for the Auth details the next time you try to interact with GitHub.

We have an open issue for a very similar scenario. We do manage to detect most cases where the Auth fails, but for some reason, this particular scenario isn't being caught.

Thank you for your prompt answer. Not 5 minutes ago I found On my Node-RED Project I typed the wrong GIT repository credentials and now it fails but wont ask for new credentials [SOLVED]. After restarting node-red I am still having problems getting it to work.

Is there a way to go back to no projects and start again without losing flows?

Thanks

Doug

Just to clarify, you have restarted Node-RED and still get this error without having been promoted for any authentication credentials?

Why would you want to go back? You can still version control locally, and I suspect you'll be able to run git push manually in ~/.node-red/projects/<name-of-project>.

Sorry I wasn't clear. No after restarting Node-Red I am prompted for credentials.

My reason for going back to the state before project mode is to wipe the slate clean. To be honest I started making changes to resolve my problem that I've made a mess of it. I'd just like to start fresh.

Doug

Nick,

Thanks for the command line information. It worked like a charm.

Really appreciated your help.

Doug