Beagle Board Black beaglebone-io module

Hi all,
I am a new user either with beagleboard black and node-red. I tried to move the first steps using the gpio nodes (thank you dceejay for your support) but a beaglebone-io module is needed. Tried to install using npm but this is the result:

root@beaglebone1:/home/debian# npm install johnny-five beaglebone-io
npm WARN checkPermissions Missing write access to /home/debian/node_modules/node-red-node-beaglebone
npm WARN enoent ENOENT: no such file or directory, open '/home/debian/package.json'
npm WARN debian No description
npm WARN debian No repository field.
npm WARN debian No README data
npm WARN debian No license field.

npm ERR! code ELOOP
npm ERR! syscall access
npm ERR! path /home/debian/node_modules/node-red-node-beaglebone
npm ERR! errno -40
npm ERR! ELOOP: too many symbolic links encountered, access '/home/debian/node_modules/node-red-node-beaglebone'

npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2020-04-14T20_09_29_153Z-debug.log

Some advise?
Thank you in advance

Ah - right - as that is a generic library that is required it may be best to install it globally for the beaglebone - maybe try

sudo npm i -g --unsafe-perm  beaglebone-io

then stop and restart Node-RED (or reboot)

1 Like

I solved using the npm command from the directory /root/....../node-red-module (or something like this) and it worked. Now I have done the first test and it is possible to control the GPIO of the BBB.
Thank you, I will come back soon with the next dubts :slight_smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.