Bigtimer node firing at wrong time

I have been using BigTimer node to turn on a floodlight at 4:45AM every morning, and off at sunrise. It's been working fine for many months, maybe more than a year. It's disabled in the node during the summer months and was supposed to resume in September.

However, ever since September 1, it's been turning on the light at midnight.

Here is the flow. Any ideas why bigtimer is turning on the light at midnight??

BTW, you should format your flow using the </> in the post editor.

Not sure if the node is pulling current time from the device running Node-Red (probably) or the device running the browser, but perhaps something has changed with the device clock?

As suggested, check the system time and timezone on the machine running node-red (not the one running the browser).
Is the Status message below the bigtimer node correct?
What is your timezone?
Does it turn on at exactly midnight?

I did. Don't know why it didn't format.

Gunner & Colin:
System time is correct. Other bigtimer nodes are working correctly- only this one seems to be off.
Node-Red is running as a component of Home Assistant on an Intel NUC i3. The OS is Hassio. The bash command 'date' shows the correct date and time.

The status message shows correctly. It is currently 7:43AM, so the timer should be off for 20:53.

big

I did reboot the host this morning, so let's see if it turns on again at midnight.

What time is reported if you run that from an exec node in your node-red instance.

I think HA use a container... I assume the timezone inside the container is also correct ?
https://nodered.org/docs/getting-started/docker#setting-timezone

It shows the correct time.

exec

I also use the light scheduler node in another flow, plus a few other instances of bigtimer that all run at the scheduled time.

In the bigtimer node you can set offset UTC.
Be sure this is set at 0 (zero) to use the system time.

Yes. Home Assistant is showing the correct date and time in the dashboard.

Are you using the latest version of the bigtimer node?

Steve

are you using NR from the HACS repository ?

If so that will be a seperate (Docker) container to HASSIO and might be where the issue is

If you have portainer running you should be able to see this and access the console of that container or through Portainer be able to expose the environment variables and confirm the TZ is set correctly

Craig

Yes, but, I have other bigtimer nodes that are working just fine. If there were a TZ problem, all of the bigtimer nodes would be affected.

Maybe it isn't an issue with the node after all?? Something else triggering those lights?

Perhaps it is time for some debug nodes throughout your flow to see what, where and when something happens tonight.

This flow is the only place that the device appears.

A couple of hours ago the node status said "Off for 7 hours". Just as I would have expected. And at midnight, the light goes on and the status changed to "On for 06hrs, 59min"

It just occurred to me.... Look at the node configuration:

Could bigtimer be interpreting the blank On Time 2 as midnight? The Off Time 2 07:00 is a failsafe. I don't recall why it's there, but I will remove it and see if the problem goes away tomorrow night.

1 Like

OK, that was the problem.
On time 2 had an end time but no start time, and bigtimer thought the blank was zero (midnight).

The goal was for the light to turn off at sunrise OR 7:00 AM, whichever occurred first.

The solution was to add the same start time to On time2.

1 Like