Bigtimer sending strange output

I had a running pi 3 with node-red on it and for various reasons I wanted to re-install the OS. Backed up the flows and re-installed the latest raspbian image 2020-02-13 buster and re-installed node-red using the script

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)

when I run the flow I get the output that looks like this.

I get the NaN output as shown in the image.
Any thoughts?

What is that location? Its possible there is no dawn at that location.

I am working on a different node and had to scan the whole year for Arctic and Antarctic regions until I found the next dawn.

PS. NaN means not a number.

I get that it is not a number and the thing is until I reloaded the flow I got the numbers out. It is a location in Canada and I'm fairly sure there is a dusk and dawn. I cannot think that there is something I missed in reloading the OS but I suppose it is possible. It's not that I rely on that info for something but in the interest of education I want to try to determine what changed or what I missed or what I did wrong.

Has the local system timezone changed ?

I'm pretty sure that I set it back to the same timezone and I've checked that about a dozen times but remember I did reload the OS. I would think that even if the timezone changed I would get something out but as @Steve-Mcl pointed out if I put in some weird place with no dusk or dawn maybe not. The lat and long are correct for southern Canada though.

To trouble shoot I disconnected all input and I noticed that the output seems to vary all by itself.

10 hrs

then goes to this

on 57

and it is not the time indicated in the timer, this occured in maybe 5 minutes and did it several times in that 5 minute period

I don't like just jumping in mid-thread, but a couple of questions and observations"

What are/were you sending into the bigtimer node?

The two pictures - though only a snapshot in time - look correct for what is written below the bigtimer node.

Maybe it would help if you exported the node (bigtimer) and pasted it here.
It would help everyone see what settings you have and/or anything you may have missed.

All you need to send bigtimer is a message auto and it does everything itself.
You don't need to keep sending it messages over and over like other nodes to get an output.

My suspicion is that in the lower picture you have sent it a message telling it to turn ON and there are 57 minutes left to the next real event. (Sun-rise/sun-set time)

The bigtimer outputs were changing on their own without any input was my problem. And when I did send a payload the outputs went hay wire without any seeming logic. I have a lot of bigtimers in different flows and like the node and I think I have a good grip on how to use them but this problem was baffling.
So.. to close the loop in desperation I completely un-installed node-red, removed all the files, deleted the directories, washed the sd card in soap and water. (not really) and re-installed everything. After the node red re-installation all is well in pi land. Must have been some freaky installation issue, don't really know.
But problem solved. Yeah!!!

Oh, well, that's good to hear.

Alas it is annoying when you have to do that to fix the problem.

But good to know you resolved it.

When you put the flows file on the new system did you recreate node_modules by doing
npm install?

I installed node-red via the script above then imported all the flows from a backup
All nodes were installed from pallete manager

That should have been OK.
For future reference, if you had put the flows file, package.json and package-lock.json in the .node-red-folder and then run (in that folder) npm install that would have installed all the nodes for you.
If you wanted the latest versions of all the nodes rather than the versions you had before then don't restore package-lock.json.

Thanks, I'll hold that info for future reference