Cannot connect to Node red instance outside local network

I have Node Red running on a Raspberry Pi 3B+. I have set up https certification with, zerossl and duckdns. Everything is OK in the settings file, and when starting it says in log file that it is listening on I have port forwarded the ports 22 and 1880 to my pi, with a static dchp ip, in my router, and I can connect to the node red instance using the dedicated dns within my local network, but once I go anywhere else, I cannot connect to But I can open an ssh connection to, is there anything I am doing wrong with node-red?

So I can connect to my pi externally using port 22, but not 1880, why? Is it something I have missed in node red?

Appreciate all answers!

I believe there is something wrong with node-red settings, or something that points to the dns address/node-red instance. If I remove the https config in settings, I can once again log in externally. But it does not work with https, although the certificate works, and is correct. I do not get any error in the logs either. Tried to set up a secondary dns to node red instance, and made it work, but got a message that the https certificate belongs to my first dns address…

Another discovery: I can connect on the original dns, only if I remove requirehttps from the settings. Which means I will not be able to connect with https…

Talking to yourself really makes you think. Figured it out. Had to set requireHttps to false, and then connect using https// That is the only way it works, cannot connect using only http connection.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.