Port Forwarding Issue connecting from outside my network

Relatively new to RPi and new to Node Red.

I have my Node RED set up on my Pi with HTTPS enabled, and I'm able to launch the Chromium browser and see the environment / dashboard. I'm also able to launch the dashboard on my networked PC via local_ip_address:1880. I'm now trying to access it from a computer not connected to my network. I tried configuring my port in my Asus router:

I temporarily disabled both the standard firewall and the IPV6 firewalls (not sure if the latter matters) in the Asus router. I also manually assigned via DHCP a static IP address for the Pi. I tried connecting the Pi wirelessly and also wired, and neither works. I restarted my router a couple of times now.

My setup is Xfinity broadband -> my own Arris modem -> Asus RT-AC88U.

I'm trying to access the dashboard from my public_IPv4_address:1880 and it times out (" This site can't be reached. IP_address unexpectedly closed the connection.")

Thanks for any additional tips you have for me!

SOLVED: I forgot to add the "https://" in front of my ip_address:port_number. Attention to detail, my friend.

Even though you have enabled https, this sounds too dangerous, I think you are at risk. There are some threads discussing this topic, using proxy servers etc. You better turn the port forwarding off and check those before you enable access from outside


There is a (partial) article in the FAQ's on this forum covering safe access to Node-RED from outside your LAN.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.