Accessing Node-Red on RasPi Standalone Network

Hi, I'm a beginner working on a Raspberry PI 3 Node-Red project.

I first connected the Raspberry PI on my home Wifi and created a flow and UI by connecting to node-red over the network using the web-browser on my laptop

My project will be used in a remote location without internet, so I want to create a standalone network hosted by the Raspberry PI. I followed this tutorial :

Now, when I'm connecting to the standalone network with my laptop, I can't access Node-Red with the web-browser. Only way I can access node-red now is directly from the Raspberry PI.

Am I doing something wrong ?

Thank you,

what IP address is the Pi now using ? usually it is part of setting up the access point. You have to point your browser at that with port 1880... so http://{access_point_IP}}:1880

Thank you for the fast reply,

I''m using the IP suggested in the tutorial: and tried accessing Node-Red with both and http://{hostname}:1880 without success

Odd thing is that I also run Grafana on the Raspberry PI and can access it successfully using port 3000. I tried running node-red on a different port, but without success.

can you log into the Pi via ssh ? - If so can you then check that Node-RED is running ? (by using node-red-stop and node-red-start commands and checking the log that then gets displayed)

Yes, I'm able to log into the Pi via ssh. I did not try the stop and start commands, but was able to confirm that Node-Red is running by accessing it directly from the Pi browser (Plugging in a monitor and a keyboard + mouse). Do you think the start up log could give me more details on why I can't access Node-Red over the Pi network ?


Is your firewall allowing traffic to access port 1880 on your device? That would be an explanation why you can reach it locally but not remotely.

When you say you can't access it, exactly what do you see on the browser?
Also what do happens if, in a terminal on the PC, you run
and finally, if running the browser on the Pi what if you enter ?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.