Not able to connect to my dashboard over public ip

I've been trying very hard to access my node re* on pi over internet. I'm using my public ip : 1880 (node red port to connect) , I've done port forwarding over my binatone router , with service port as 1880 and internal port as 1880 with local IP. Please, I'm running out of time. I've tried local tunnel but its not working (cli is stuck at lt -p 1880 -o)

I don't want to use ngrok as it'll start a new tunnel every time my pi reboots. I think my router is not really opening up the ports, I've tried checking that with its showing that my port is closed. Is it my router? I'm very confused please help me out i visited a ton of websites but couldn't find anything related to my problem, and I disabled my firewall too.

Yes it could be your router but I would also look at your ISP. I have seen many ISP's that block port ranges to "reduce attack surface" (which does not help). My previous ISP blocked 25 incoming, took some time to get that fixed :slight_smile:

Try another port from the outside (eg. 80 or 443) and forward to 1880 internal. This will provide more clarity. Second thing to look at, your IP address, because of the shortage on IP4 addresses, static/fixed IP addresses are no longer available from the ISP. Might be obvious but are you sure you have the right IP??

I hope you are aware that once you succeed in connecting, unless you've properly secured your node-red and your Pi, you will soon be mining crypto-currency for criminals.


thank you , and yes i think its my isp too. ive port forwaded many ports to internal.

thank you , is there any very good and easy way to secure my connection, its still not established though

There are a number of good ways, but all of them require some learning and work.
Look in the User Guide in the node red docs and there is a section on securing node red, and search the forum for 'secure' and you will find a number of threads about it with some alternative suggestions.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.