Cannot GET /zigbee2mqtt/showMap

I'm using node-red-contrib-zigbee2mqtt for my Zigbee devices, works all great.
In the Zigbee bridge node there's a tab with the option to generate a map of my Zigbee network, this works also great.
However on this tab there's also a button "Open in full screen", if this is pressed we get an empty web page with the error Cannot GET /zigbee2mqtt/showMap, in the url of my browser is http://192.168.1.127:1880/zigbee2mqtt/showMap?controllerID=fcbfb445.44989 , this all looks fine to me.
I'm sure it was working a couple of months ago.
What can be the problem or where to look to tackle the problem?

Nr V2.0.3, Dashboard 2.30.0

It is working for me, which doesn't help much except to prove that it not a node problem.

A few things to try (which to probably already have)
Refresh the page and try repeating the map selection.
Have a look at the empty web page with Dev Tools to see if there are any clues there. I get
<!-- Generated by graphviz version 2.40.1 (20161225.0304) -->
at the top of the guff, followed by an svg element

Have pop-ups been disabled in your browser?

My status;
NR v2.0.6, Dashboard 3.0.4, node-red-contrib-zigbee2mqtt 0.6.9

So not sure if that makes any difference

url is 192.168.1.21:1880/zigbee2mqtt/showMap?controllerID=83162ab9.755208 which is pretty much the same. I am using Edge, again not sure if that makes any difference

Thanks for the help.

Mmmh, I remember now that I have changed something in the settings.js (httpAdminRoot: '/admin',) to get some icons installed.
Opening the NR editor must be done now with http://192.168.1.127:1880/admin/.
Tried opening the Zigbee map with the /admin in the url http://192.168.1.127:1880/admin/zigbee2mqtt/showMap?controllerID=fcbfb445.44989 and that's works, the map is shown full screen.

Now to find out how to get this url called by the button in the bridge node....

As an option have a look at the build-in frontend which includes a map and more.

I think that is a bug in the node? It has attached to the admin ExpressJS app instead of the user one.

There is also a flow called Z2M Admin which is a bit simpler than Frontend but is pure Node-RED

I don't see the advantage of using contrib-zigbee2mqtt. For data exchange you can use the core mqtt nodes (less maintenance and trouble). For settings the frontend is really handy.

The only value of the map is showing the inter-connectivity. Not sure if that data is available via MQTT and even if it were, you might still want to build a map (strictly speaking, the display is a "Graph").

Personally, I find browser bookmarks or web pages with links more than good enough to take me to the right page without messing with iframes and other complexities.

No need of MQTT for the build-in frontend. It's very easy to configure, open a browser with the zigbee2mqtt ip address and click the Map tab. Try yourself and you'll never want to miss it. :grinning:

I believe that it is necessary to include this in the zigbee2mqtt configuration file to enable the web frontend feature.

frontend:
  port: 8080

Just click the link I've already posted but especially for you :grinning: here the details:

configuration.yaml:

frontend:
  # Optional, default 8080
  port: 8080
  # Optional, default 0.0.0.0
  host: 0.0.0.0
  # Optional, enables authentication, disabled by default
  auth_token: your-secret-token

I already use it, I was just pointing out to others that this may not work out of the box, it is necessary to specify the option in the config file, which I don't think was necessarily made clear.

Again see my link above, that's enough clear :wink:

Clarity is in the eye of the beholder :slight_smile:

That's what I was saying, and that's what I do :slight_smile: Just put the link into the Dashboard instead of trying to integrate.

Sure! but this forum is for adults, so we don't need a milk bottle. :slightly_smiling_face: