Cannot install node-red-contrib-ttn in Windows

Sorry, I'm sure this is a very common issue but can't quickly spot a solution online.

I have a NR installation running fine under Win32 and wish to add node-red-contrib-ttn. But:

npm install -g node-red-contrib-ttn

errors out with 'No git binary found in $PATH'. I'm sure I don't know enough about Windows paths and npm. Be most grateful if anyone could spell out what I need to do please or point me to a relevant online resource.

If you search the forum with that error message you will find this thread which contains suggestions of what to do Node-red-contib-ttn Installing ERROR

Should have said: I already tried that and it gives the same error. Looks like I should be editing $PATH to include some additional git folder or pointer but clueless as to exactly what to add.

Edit: Maybe I don't have git installed and the ttn node installation expects it to be there? Is that a reasonable surmise? So maybe a solution is to look to install git on this Windows box? I can't currently see any git folder under C:\Program Files\Git... Is that where I might expect it to be if it was installed?

The nodes readme on github has the helpful comment

Make sure you have git installed.

As you say you've done that you can either wait and see if someone who has done it answers your post, and/or open an issue on the nodes github page where hopefully the author can explain what you need to do and also update the nodes docs to help others.

OK. Installed git for Win32 from Still wouldn't play!

Had to edit the PATH variable manually to include C:\Program Files\Git\bin and then bingo!

Not v obvious how to do so, but opening a System dialogue and searching for Environment showed the way. In the git install there are many options - I just accepted all the defaults bar opting to use VSC as the text editor. Maybe one of the options would have updated the PATH automatically?

Now to find out if the TTN node actually works! Many thanks ukmoose for prompting me along!

Glad you got it to work, can you also add an issue to the nodes github page explaining what you did, hopefully they can then amend their instructions to allow other people to more easily install it in future

I'm a github newbie, but the TTN node page seems is saying: 'This repository has been archived by the owner. It is now read-only.' Can't see any obvious way of raising a new issue.

Yes, it isn't being developed any more.

You have a couple of choices. Either fork the repository and create your own variant.

Or, use the TTN API's directly without help from a specific node. There seem to be some examples of this in the flows library?

Really I was just trying to follow up ukmoose's suggestion of flagging up the installation issue I encountered. But now that I do have it successfully installed, initial indications are that the node is working fine. So from my point of view I'm happy to leave it there.