Can't connect to any MQTT broker

Hi everyone !
I am trying to connect to my MQTT broker from Node-RED.
I have RabbitMQ installed with MQTT plugin activated. It is listening on port 1883. When I trie to connect to it with an MQTT node, I get this error in Node-RED's logs :

[mqtt-broker:11b4b29f.2e05fd] Connection failed to broker: mqtt://

In the same time, Node-RED is connected with RabbitMQ with AMQP node and this is working fine.
So I tried to connect Node-RED to public brokers (,,...) but I always get the same error, so I think the issue comes from Node-RED...
Do you know a way to fix this ?

(I have everything running in Docker and using nodered/node-red-docker:rpi-v8 image)

Thank's :slight_smile:

I installed a Mosquitto broker on another local machine ( and it worked with Node-RED.
But why doesn't it work with remote brokers nor RabbitMQ broker ?

Sounds like this will be a firewall issue. Check any firewalls between Node-RED and the public brokers and make sure that outbound port 1883 is open.