Connection failed to broker: mqtt ://192.168.1.8:1883

Hi Can someone help me with this.
Have disabled Firewall just in case, but am not able to connect.
I am sorry but i am very new at this.

C:>NOdE-Red
17 Oct 12:22:10 - [info]
Welcome to Node-RED

17 Oct 12:22:10 - [info] Node-RED version: v2.0.6
17 Oct 12:22:10 - [info] Node.js version: v13.14.0
17 Oct 12:22:10 - [info] Windows_NT 6.1.7601 x64 LE
17 Oct 12:22:10 - [info] Loading palette nodes
17 Oct 12:22:11 - [info] Settings file : C:\Users\Admin.node-red\settings.js
17 Oct 12:22:11 - [info] Context store : 'default' [module=memory]
17 Oct 12:22:11 - [info] User directory : \Users\Admin.node-red
17 Oct 12:22:11 - [warn] Projects disabled : editorTheme.projects.enabled=false
17 Oct 12:22:11 - [info] Flows file : \Users\Admin.node-red\flows.json
17 Oct 12:22:11 - [info] Server now running at http://127.0.0.1:1880/
17 Oct 12:22:11 - [warn]


Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.
17 Oct 12:22:11 - [info] Starting flows
17 Oct 12:22:11 - [info] Started flows
17 Oct 12:22:12 - [info] [mqtt-broker:Broker1] Connection failed to broker: mqtt
://192.168.1.8:1883

If you are using mosquitto v2.x you need to modify the conf file to allow external connections.

It's been covered quite a few times (search the forum)

1 Like

Got It thanks a Lot.