Can't get sqlite node installed

I have node-red running on a Raspberry PI 3+.
Having an issue installing/running since attempting to install node-red-node-sqlite module.
After restarting node-red I get the following:

Welcome to Node-RED

3 Jan 17:44:36 - [info] Node-RED version: v0.19.5
3 Jan 17:44:36 - [info] Node.js version: v10.14.2
3 Jan 17:44:36 - [info] Linux 4.14.79-v7+ arm LE
3 Jan 17:44:38 - [info] Loading palette nodes
3 Jan 17:44:48 - [info] Dashboard version 2.13.0 started at /ui
3 Jan 17:44:51 - [warn] ------------------------------------------------------
3 Jan 17:44:51 - [warn] [node-red-node-sqlite/sqlite] Error: Cannot find module '/home/pi/.node-red/node_modules/sqlite3/lib/binding/node-v64-linux-arm/node_sqlite3.node'
3 Jan 17:44:51 - [warn] ------------------------------------------------------
3 Jan 17:44:51 - [info] Settings file : /home/pi/.node-red/settings.js
3 Jan 17:44:51 - [info] Context store : 'default' [module=memory]
3 Jan 17:44:51 - [info] User directory : /home/pi/.node-red
3 Jan 17:44:51 - [warn] Projects disabled : editorTheme.projects.enabled=false
3 Jan 17:44:51 - [info] Flows file : /home/pi/.node-red/flows_raspberrypi.json
3 Jan 17:44:51 - [info] Server now running at
3 Jan 17:44:51 - [warn]

Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

3 Jan 17:44:51 - [info] Waiting for missing types to be registered:
3 Jan 17:44:51 - [info] - sqlitedb

When I view the localhost:1880 I get a popup stating:
Flow stopped due to missing node types.

How do I resolve this issue. My node-red is dead in the water with this failure.


Did you follow the readme instructions ?
It can take about 20 mins to recompile itself and install. Was there any error reported as it installed ?

Never saw the readme instructions.
But that's water over the dam now.
So how do I fix the issue?

I suggest you go and read them before you do anything else.

Run it as per the instructions...

Thanks. I think i'm to the point of uninstalling node-red and reinstalling it.

Reinstalling Node-RED itself won't have any bearing on any extra modules you've tried to install - unless you mean a full wipe and start from scratch.

Before you do that, try:

  1. go to /home/pi/.node-red/
  2. run npm rebuild sqlite3
1 Like

This worked. I no longer get the node-red startup issues and the sqlite node is present.
Thanks for your Very Helpful reply.

Worked for me too thanks knolleary & ecjmiddl.
My thanks to all the contributors who assisted in my endeavors to get sqlite installed. Being new to node-red I found installing this node a challenge. I set out my final process below in the hope it might assist others.

My initial attempts at installing sqlite on a Pi Zero via "npm i --unsafe-perm node-red-node-sqlite"
failed as I erroneously assumed I had a lock up while in fact it was compiling. Took approx 15 minutes before a raft of messages gave an insight something was actually taking place.

After a restart I remained frustrated as while the palette manager advised sqlite node was now installed it was not showing and there was a nice little red triangle with exclamation mark.

A review of the start up script gave me the message:
[warn] [node-red-node-sqlite/sqlite] Error: Cannot find module '/home/pi/.node-red/node_modules/node-red-node-sqlite/node_modules/sqlite3/lib/binding/node-v57-linux-arm/node_sqlite3.node'

Then "npm rebuild sqlite3" fixed this, red triangle is no more and node showing.

Think it would be worth adding a rider to the node instructions about the lengthy compile and that the rebuild command will fix the red triangle.

Thanks - have added to the readme

Rebuild sqlite3 has also solved the issue for me. I was updating node-red with the bash script on, coming from version 1.0.1, going to 1.1.2, node.js v8.11.1 to v12.16.3