Can't start NR on a new Windows 10 PC

Running Powershell as Administrator under Win10:Home entering node-red at the prompt gives 'node-red.ps1 cannot be loaded because running scripts is disabled on
this system. For more information, see about_Execution_Policies at https:/'

This is a personal PC with a default install. I could spend an hour or two fiddling with Execution Policies without really knowing exactly what I'm doing. Is there a simple fix please that doesn't also open me up to potentially running some malware scripts?

Why are you trying to run Node-RED as Administrator? it shouldn't need it.

Doesn't make any difference whether I run Powershell as Admin or not.

But I've just tried reverting to Command Prompt and - hooray - that works OK. Obviously Powershell under fully updated Win10 must be invoking some extra security checks that Command Prompt doesn't do.

Not sure whether I'll run into other issues under Windows - I could potentially run on a Pi instead, but Windows is my default desktop machine and it's just quicker and easier to use that PC. Anyway, problem solved for the time being. Sorry, I probably reached for support too quickly, but it looked like a bigger/more obscure issue.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.